summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-11 21:02:19 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-11 21:10:11 +0200
commit41a572ffb5af63c11f26084a32b94ce2a11651f3 (patch)
treec8500599a0e4ed26241529cdc3ecdb21c101cb59 /dev-python/natsort
parentdev-python/natsort: add 8.0.1 (diff)
downloadgentoo-41a572ffb5af63c11f26084a32b94ce2a11651f3.tar.gz
gentoo-41a572ffb5af63c11f26084a32b94ce2a11651f3.tar.bz2
gentoo-41a572ffb5af63c11f26084a32b94ce2a11651f3.zip
dev-python/natsort: add optfeature
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/natsort')
-rw-r--r--dev-python/natsort/natsort-8.0.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/natsort/natsort-8.0.1.ebuild b/dev-python/natsort/natsort-8.0.1.ebuild
index e1a2a2c8074f..2e369a39667d 100644
--- a/dev-python/natsort/natsort-8.0.1.ebuild
+++ b/dev-python/natsort/natsort-8.0.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 optfeature
DESCRIPTION="Natural sorting for Python"
HOMEPAGE="https://pypi.org/project/natsort/"
@@ -21,3 +21,7 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "sorting results that match most file browsers" "dev-python/pyicu"
+}