summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-12 08:58:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-12 09:36:14 +0100
commitdb606a97c95910373df107f6369eb49f7b4438ed (patch)
treea28bc178bce06e913deaf7a2e7964eff2420dfad /dev-python/nbclassic/nbclassic-0.3.5.ebuild
parentapp-admin/awscli: Bump to 1.22.33 (diff)
downloadgentoo-db606a97c95910373df107f6369eb49f7b4438ed.tar.gz
gentoo-db606a97c95910373df107f6369eb49f7b4438ed.tar.bz2
gentoo-db606a97c95910373df107f6369eb49f7b4438ed.zip
dev-python/nbclassic: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclassic/nbclassic-0.3.5.ebuild')
-rw-r--r--dev-python/nbclassic/nbclassic-0.3.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/nbclassic/nbclassic-0.3.5.ebuild b/dev-python/nbclassic/nbclassic-0.3.5.ebuild
new file mode 100644
index 000000000000..07ca7eea2bc7
--- /dev/null
+++ b/dev-python/nbclassic/nbclassic-0.3.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/nbclassic/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv ${PN}/conftest.py . || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}