summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 15:11:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 15:11:10 +0100
commitf7852d923a8b80399fab9ba2de152a404c416fc7 (patch)
tree566bf22f01074f0e14c87d5f6e1415a4eca4e2a0 /dev-python/openapi-core
parentdev-python/jupyterlab_server: Remove old (diff)
downloadgentoo-f7852d923a8b80399fab9ba2de152a404c416fc7.tar.gz
gentoo-f7852d923a8b80399fab9ba2de152a404c416fc7.tar.bz2
gentoo-f7852d923a8b80399fab9ba2de152a404c416fc7.zip
dev-python/openapi-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.14.5.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index dc5235c96ea5..701dc5043af0 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,2 +1 @@
-DIST openapi-core-0.14.5.gh.tar.gz 57645 BLAKE2B c5c9c308b93a37e32708677cc7c7a2ccb9ec3f018390e56a251224b6b8776943ccd0ddfb560cdc3f1182cb32a9b2817878a0d4dda3906c179db9841853caf7ac SHA512 69d9fb2cc21dfdb939beae45b1c681faf9f8e3366b36e5907b00be65ac669ec40e3ae3fe910fb2c4f6c70d1412e6a67e4e4e47e3cf2c424716da4c813223295e
DIST openapi-core-0.16.5.gh.tar.gz 104046 BLAKE2B 7dcda69b6d548a0df8c7727b184c7f7ec6d645e14ab4b4a256f188c6cc4ae9e351bc06ae03770782d81a11dfb5ebc08c20daabbd2151cfe62f84b05f80a47a16 SHA512 59db6d39a950079739b2df4114f26d85be55dc1f42d1661e8e6c17cf878cd8167f29ba4d3b6f40e06e85bb144c68286cb50adf4403091461798144cac05d5bc0
diff --git a/dev-python/openapi-core/openapi-core-0.14.5.ebuild b/dev-python/openapi-core/openapi-core-0.14.5.ebuild
deleted file mode 100644
index 1f9a309918f0..000000000000
--- a/dev-python/openapi-core/openapi-core-0.14.5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
-HOMEPAGE="
- https://github.com/p1c2u/openapi-core/
- https://pypi.org/project/openapi-core/
-"
-SRC_URI="
- https://github.com/p1c2u/openapi-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/dictpath[${PYTHON_USEDEP}]
- <dev-python/openapi-schema-validator-0.3[${PYTHON_USEDEP}]
- <dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # falcon is not packaged
- tests/integration/contrib/falcon
-
- # TODO: these tests fail to collect
- tests/integration/validation/test_security_override.py
- tests/integration/validation/test_read_only_write_only.py
-
- # unhappy about modern django
- tests/integration/contrib/test_django.py
- tests/integration/contrib/django
-)
-
-EPYTEST_DESELECT=(
- # too new pytest?
- tests/unit/unmarshalling/test_unmarshal.py::TestSchemaUnmarshallerCall::test_string_format_invalid_value
-)
-
-src_prepare() {
- sed -i -e '/addopts/d' setup.cfg || die
- distutils-r1_src_prepare
-}