summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-19 09:16:57 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-19 09:19:28 -0500
commit5857fc41461c38e43444fdd9a1273641e60259cd (patch)
treeaa16d3f79e666fe4e1eca53d950cae5912d13404 /dev-python/os-testr/os-testr-0.8.0.ebuild
parentdev-python/os-win: bup (diff)
downloadgentoo-5857fc41461c38e43444fdd9a1273641e60259cd.tar.gz
gentoo-5857fc41461c38e43444fdd9a1273641e60259cd.tar.bz2
gentoo-5857fc41461c38e43444fdd9a1273641e60259cd.zip
dev-python/os-testr: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/os-testr/os-testr-0.8.0.ebuild')
-rw-r--r--dev-python/os-testr/os-testr-0.8.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/os-testr/os-testr-0.8.0.ebuild b/dev-python/os-testr/os-testr-0.8.0.ebuild
new file mode 100644
index 000000000000..b2a2b6245909
--- /dev/null
+++ b/dev-python/os-testr/os-testr-0.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A testr wrapper to provide functionality for OpenStack projects"
+HOMEPAGE="https://pypi.python.org/pypi/os-testr https://github.com/openstack/os-testr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-3.7.00[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}