summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-07 05:04:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-07 05:15:10 +0200
commit2de9bbf5132ef904d626ba3f9ef86a8e936922c2 (patch)
tree09847c8517cace5328bd72aa0401a86da95c9f37 /dev-python/oslo-utils
parentdev-python/python-neutronclient: Bump to 11.0.0 (diff)
downloadgentoo-2de9bbf5132ef904d626ba3f9ef86a8e936922c2.tar.gz
gentoo-2de9bbf5132ef904d626ba3f9ef86a8e936922c2.tar.bz2
gentoo-2de9bbf5132ef904d626ba3f9ef86a8e936922c2.zip
dev-python/oslo-utils: Bump to 6.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-utils')
-rw-r--r--dev-python/oslo-utils/Manifest1
-rw-r--r--dev-python/oslo-utils/oslo-utils-6.2.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index a83943f11f47..47a69b581c42 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1 +1,2 @@
DIST oslo.utils-6.1.0.tar.gz 102843 BLAKE2B 8bf3889bcf82fd12589c58b2020164f1183fa9ed19491a05d252a6157841651259e3b2f412affb5d53eff4bf7f21e34a4666fdb91106652a937c79b5fd9c1c14 SHA512 ae86fe4dfe2db25c682ee533a16830fc3e03eb408ae4acd832b6aded9d7d93fd91927444f054b594b4834e338c8f13c48d0c9796b224923adc1d0df7f6cfb84a
+DIST oslo.utils-6.2.0.tar.gz 103944 BLAKE2B b4637cb94c3b4923c5cb2203f78591e4cbe22a0fc71bd9f798277ddf4931adf48944972c782c253ebbd8108fb16f59b8d23b1ae4530d68480e44dec723b26983 SHA512 f1c378028775db19a13e5c1879b40742a171001f5044408995ff997cfb9cc7c815476f51744bf09f44c90672247fb2dff8ddc955bcd8749ea0066d5b79d0af34
diff --git a/dev-python/oslo-utils/oslo-utils-6.2.0.ebuild b/dev-python/oslo-utils/oslo-utils-6.2.0.ebuild
new file mode 100644
index 000000000000..c889c6445f5f
--- /dev/null
+++ b/dev-python/oslo-utils/oslo-utils-6.2.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Utility library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.utils/
+ https://github.com/openstack/oslo.utils/
+ https://pypi.org/project/oslo.utils/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.2.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}"/install -name '*eventletutils*' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}