summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-05 06:16:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-05 06:37:35 +0100
commitf954275e5d2070f2f63bf69af1689442451f8d50 (patch)
tree109905190eca4f29157c069909ef626135cb5f85 /dev-python/oslo-utils
parentdev-python/apsw: Bump to 3.47.1.0 (diff)
downloadgentoo-f954275e5d2070f2f63bf69af1689442451f8d50.tar.gz
gentoo-f954275e5d2070f2f63bf69af1689442451f8d50.tar.bz2
gentoo-f954275e5d2070f2f63bf69af1689442451f8d50.zip
dev-python/oslo-utils: Add cdrtools test dep for mkisofs
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-utils')
-rw-r--r--dev-python/oslo-utils/oslo-utils-8.0.0.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-python/oslo-utils/oslo-utils-8.0.0.ebuild b/dev-python/oslo-utils/oslo-utils-8.0.0.ebuild
index 9a8e2700c1e1..187cae23b9d5 100644
--- a/dev-python/oslo-utils/oslo-utils-8.0.0.ebuild
+++ b/dev-python/oslo-utils/oslo-utils-8.0.0.ebuild
@@ -8,7 +8,7 @@ PYPI_NO_NORMALIZE=1
PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 pypi
+inherit check-reqs distutils-r1 pypi
DESCRIPTION="Oslo Utility library"
HOMEPAGE="
@@ -36,6 +36,7 @@ RDEPEND="
BDEPEND="
>=dev-python/pbr-2.2.0[${PYTHON_USEDEP}]
test? (
+ app-cdr/cdrtools
app-emulation/qemu
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
@@ -47,6 +48,17 @@ BDEPEND="
distutils_enable_tests unittest
+# note this only applies to USE=test
+CHECKREQS_DISK_BUILD=8G
+
+pkg_pretend() {
+ use test && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use test && check-reqs_pkg_setup
+}
+
src_prepare() {
distutils-r1_src_prepare