summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-10-19 22:51:44 -0400
committerMike Gilbert <floppym@gentoo.org>2015-10-19 23:09:33 -0400
commit7db32bc8ba0e8f455c6a3222f6926299012674e9 (patch)
tree95bb3db905c26f805b8230d74c9c86a569094780 /dev-python/packaging/files
parentdev-qt/qtcore: fix build on ia64 (diff)
downloadgentoo-7db32bc8ba0e8f455c6a3222f6926299012674e9.tar.gz
gentoo-7db32bc8ba0e8f455c6a3222f6926299012674e9.tar.bz2
gentoo-7db32bc8ba0e8f455c6a3222f6926299012674e9.zip
dev-python/packaging: Force setup.py to use distutils
Bug: https://bugs.gentoo.org/563534 Package-Manager: portage-2.2.23_p4
Diffstat (limited to 'dev-python/packaging/files')
-rw-r--r--dev-python/packaging/files/packaging-15.3-distutils.patch (renamed from dev-python/packaging/files/packaging-15.3-setuptools.patch)18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-python/packaging/files/packaging-15.3-setuptools.patch b/dev-python/packaging/files/packaging-15.3-distutils.patch
index abb0662cc56f..bd3b8ccebe97 100644
--- a/dev-python/packaging/files/packaging-15.3-setuptools.patch
+++ b/dev-python/packaging/files/packaging-15.3-distutils.patch
@@ -1,25 +1,19 @@
- setup.py | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
+Force setup.py to use distutils
+
+Bug: https://bugs.gentoo.org/563534
-diff --git a/setup.py b/setup.py
-index 13c9dad..9d68590 100644
--- a/setup.py
+++ b/setup.py
-@@ -15,7 +15,12 @@
+@@ -15,7 +15,7 @@
from __future__ import absolute_import, division, print_function
import os
-import setuptools
-+
-+try:
-+ from setuptools import setup
-+except ImportError:
-+ from distutils.core import setup
-+
++from distutils.core import setup
base_dir = os.path.dirname(__file__)
-@@ -31,7 +36,7 @@ with open(os.path.join(base_dir, "CHANGELOG.rst")) as f:
+@@ -31,7 +31,7 @@ with open(os.path.join(base_dir, "CHANGELOG.rst")) as f:
long_description = "\n".join([long_description, f.read()])