summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-07 20:12:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-07 20:16:46 +0200
commitece58aa44ab57bd0cb40152251859b0b3b740c2c (patch)
tree29d99a7911fbd7eadde3e4eb11f79ad37b7809e0 /dev-python/pandas
parentdev-libs/libclc: Add 18.1.7 (diff)
downloadgentoo-ece58aa44ab57bd0cb40152251859b0b3b740c2c.tar.gz
gentoo-ece58aa44ab57bd0cb40152251859b0b3b740c2c.tar.bz2
gentoo-ece58aa44ab57bd0cb40152251859b0b3b740c2c.zip
dev-python/pandas: Restrict dev-python/tables dep to LE
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/pandas-2.2.1-r1.ebuild6
-rw-r--r--dev-python/pandas/pandas-2.2.1.ebuild6
-rw-r--r--dev-python/pandas/pandas-2.2.2-r1.ebuild6
-rw-r--r--dev-python/pandas/pandas-2.2.2.ebuild6
4 files changed, 16 insertions, 8 deletions
diff --git a/dev-python/pandas/pandas-2.2.1-r1.ebuild b/dev-python/pandas/pandas-2.2.1-r1.ebuild
index 360e1d07a141..d7f511b19791 100644
--- a/dev-python/pandas/pandas-2.2.1-r1.ebuild
+++ b/dev-python/pandas/pandas-2.2.1-r1.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~riscv"
-IUSE="full-support minimal test X"
+IUSE="big-endian full-support minimal test X"
RESTRICT="!test? ( test )"
RECOMMENDED_DEPEND="
@@ -42,7 +42,6 @@ OPTIONAL_DEPEND="
>=dev-python/matplotlib-3.6.1[${PYTHON_USEDEP}]
>=dev-python/openpyxl-3.0.7[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.4.36[${PYTHON_USEDEP}]
- >=dev-python/tables-3.7.0[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.8.10[${PYTHON_USEDEP}]
>=dev-python/xarray-2022.3.0[${PYTHON_USEDEP}]
>=dev-python/xlrd-2.0.1[${PYTHON_USEDEP}]
@@ -52,6 +51,9 @@ OPTIONAL_DEPEND="
>=dev-python/scipy-1.8.1[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
) ) ) )
+ !big-endian? (
+ >=dev-python/tables-3.7.0[${PYTHON_USEDEP}]
+ )
X? (
|| (
>=dev-python/PyQt5-5.15.6[${PYTHON_USEDEP}]
diff --git a/dev-python/pandas/pandas-2.2.1.ebuild b/dev-python/pandas/pandas-2.2.1.ebuild
index 2f918de587c8..48f9b26fe9a6 100644
--- a/dev-python/pandas/pandas-2.2.1.ebuild
+++ b/dev-python/pandas/pandas-2.2.1.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~hppa ~loong ~riscv x86"
-IUSE="full-support minimal test X"
+IUSE="big-endian full-support minimal test X"
RESTRICT="!test? ( test )"
RECOMMENDED_DEPEND="
@@ -42,7 +42,6 @@ OPTIONAL_DEPEND="
>=dev-python/matplotlib-3.6.1[${PYTHON_USEDEP}]
>=dev-python/openpyxl-3.0.7[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.4.36[${PYTHON_USEDEP}]
- >=dev-python/tables-3.7.0[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.8.10[${PYTHON_USEDEP}]
>=dev-python/xarray-2022.3.0[${PYTHON_USEDEP}]
>=dev-python/xlrd-2.0.1[${PYTHON_USEDEP}]
@@ -52,6 +51,9 @@ OPTIONAL_DEPEND="
>=dev-python/scipy-1.8.1[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
) ) ) )
+ !big-endian? (
+ >=dev-python/tables-3.7.0[${PYTHON_USEDEP}]
+ )
X? (
|| (
>=dev-python/PyQt5-5.15.6[${PYTHON_USEDEP}]
diff --git a/dev-python/pandas/pandas-2.2.2-r1.ebuild b/dev-python/pandas/pandas-2.2.2-r1.ebuild
index 0b4c750cbd70..30280685ccba 100644
--- a/dev-python/pandas/pandas-2.2.2-r1.ebuild
+++ b/dev-python/pandas/pandas-2.2.2-r1.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~hppa ~loong ~riscv ~x86"
-IUSE="full-support minimal test X"
+IUSE="big-endian full-support minimal test X"
RESTRICT="!test? ( test )"
RECOMMENDED_DEPEND="
@@ -42,7 +42,6 @@ OPTIONAL_DEPEND="
>=dev-python/matplotlib-3.6.1[${PYTHON_USEDEP}]
>=dev-python/openpyxl-3.0.7[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.4.36[${PYTHON_USEDEP}]
- >=dev-python/tables-3.7.0[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.8.10[${PYTHON_USEDEP}]
>=dev-python/xarray-2022.3.0[${PYTHON_USEDEP}]
>=dev-python/xlrd-2.0.1[${PYTHON_USEDEP}]
@@ -52,6 +51,9 @@ OPTIONAL_DEPEND="
>=dev-python/scipy-1.8.1[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
) ) ) )
+ !big-endian? (
+ >=dev-python/tables-3.7.0[${PYTHON_USEDEP}]
+ )
X? (
|| (
>=dev-python/PyQt5-5.15.6[${PYTHON_USEDEP}]
diff --git a/dev-python/pandas/pandas-2.2.2.ebuild b/dev-python/pandas/pandas-2.2.2.ebuild
index 2b6004916e2d..9b6a5d2b7ffa 100644
--- a/dev-python/pandas/pandas-2.2.2.ebuild
+++ b/dev-python/pandas/pandas-2.2.2.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~hppa ~loong ~riscv x86"
-IUSE="full-support minimal test X"
+IUSE="big-endian full-support minimal test X"
RESTRICT="!test? ( test )"
RECOMMENDED_DEPEND="
@@ -42,7 +42,6 @@ OPTIONAL_DEPEND="
>=dev-python/matplotlib-3.6.1[${PYTHON_USEDEP}]
>=dev-python/openpyxl-3.0.7[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.4.36[${PYTHON_USEDEP}]
- >=dev-python/tables-3.7.0[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.8.10[${PYTHON_USEDEP}]
>=dev-python/xarray-2022.3.0[${PYTHON_USEDEP}]
>=dev-python/xlrd-2.0.1[${PYTHON_USEDEP}]
@@ -52,6 +51,9 @@ OPTIONAL_DEPEND="
>=dev-python/scipy-1.8.1[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
) ) ) )
+ !big-endian? (
+ >=dev-python/tables-3.7.0[${PYTHON_USEDEP}]
+ )
X? (
|| (
>=dev-python/PyQt5-5.15.6[${PYTHON_USEDEP}]