summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 21:17:04 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 09:05:16 +0200
commitb4a9a7581f32272928f2a046fcbb1d7dbcfc593e (patch)
tree5b7e03133d17662d4aa96f85dae0ad5e3d5b37c8 /dev-python/paramiko
parentdev-python/paramiko: Drop old (diff)
downloadgentoo-b4a9a7581f32272928f2a046fcbb1d7dbcfc593e.tar.gz
gentoo-b4a9a7581f32272928f2a046fcbb1d7dbcfc593e.tar.bz2
gentoo-b4a9a7581f32272928f2a046fcbb1d7dbcfc593e.zip
dev-python/paramiko: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest1
-rw-r--r--dev-python/paramiko/paramiko-1.15.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index 77a520fc6f8e..2b56f3753931 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -1,2 +1,3 @@
DIST paramiko-1.15.1.tar.gz 1219256 SHA256 6ed97e2281bb48728692cdc621f6b86a65fdc1d46b178ce250cfec10b977a04c SHA512 146076792e42965aaca08e74630c18422ed767a3da64c63fa63da9a464e1dade5a3f77635a5aae569e5a382d9a31eb4ee738399cd93895e355b4a57119c99f1c WHIRLPOOL 4f4bb6276363130d14c80e55d5c6858712a25404735e9671969d79ff1d1b1399918e24b6c80b275bbf76373a95cb407ca34fba5da8bc92bcd1322e4651ad1354
DIST paramiko-1.15.2.tar.gz 1220578 SHA256 4f56a671a3eecbb76e6143e6e4ca007d503a39aa79aa9e14ade667fa53fd6e55 SHA512 c8fe6c5e4c99ac0922c08f3c006b55852f54c3043eb3ddae5b6e5fba0592bf08b10ec399ec6865bbe84c759c8a15a00722247409b666f42e93b18bfd658158cd WHIRLPOOL 477e9e3d93f4faa9471c2a3e87ac96e7fe0ecdbdfb838b348ba2873e4bc408e78a5840f02002db6bbea18de8b9e2c83240db5a3c16543e4949ea62250de7a26a
+DIST paramiko-1.15.3.tar.gz 1212786 SHA256 7e17ec363c73acb0e77a5fcc6e44a0dd494339a9067e99a997a7d32b4272fef1 SHA512 60e9b55985bf575a2a0f37c63ee183a247652b51b23573ea0ae3a8304418cdb7f91cf661a577cc04d06ea9ef644a24ea0e985a80ee6f7c137e5eee6bd172b332 WHIRLPOOL 329748854b4a97c3f52daa5619a7eee7f33217b524d9baa6f761ee25abc9e578c457599a8385b9813dfb973bcc6ef83c3d10d9527002ac88f4477e384115f860
diff --git a/dev-python/paramiko/paramiko-1.15.3.ebuild b/dev-python/paramiko/paramiko-1.15.3.ebuild
new file mode 100644
index 000000000000..4ca3739cc12c
--- /dev/null
+++ b/dev-python/paramiko/paramiko-1.15.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="http://www.paramiko.org/ https://github.com/paramiko/paramiko/ https://pypi.python.org/pypi/paramiko/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/pycrypto-2.1[${PYTHON_USEDEP}]
+ !=dev-python/pycrypto-2.4[${PYTHON_USEDEP}]
+ >=dev-python/ecdsa-0.11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Required for testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ "${PYTHON}" test.py --verbose || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local EXAMPLES=( demos/. )
+
+ distutils-r1_python_install_all
+}