summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 08:45:42 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 08:50:39 +0100
commitf27e72051d86971bcc1876d4689a9acc47a0a665 (patch)
tree46670d6e6aaab8b7c5bacc56c894cb1beac65916 /dev-python/paramiko
parentdev-ruby/rack: Stabilize 2.2.6.2 ppc64, #895664 (diff)
downloadgentoo-f27e72051d86971bcc1876d4689a9acc47a0a665.tar.gz
gentoo-f27e72051d86971bcc1876d4689a9acc47a0a665.tar.bz2
gentoo-f27e72051d86971bcc1876d4689a9acc47a0a665.zip
dev-python/paramiko: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest1
-rw-r--r--dev-python/paramiko/files/paramiko-2.12.0-pytest-relaxed.patch93
-rw-r--r--dev-python/paramiko/paramiko-2.12.0.ebuild61
3 files changed, 0 insertions, 155 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index f1b32d05ad16..61fca35b2344 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -1,2 +1 @@
-DIST paramiko-2.12.0.gh.tar.gz 351956 BLAKE2B d41668f32f28a5c2c3af1d2b5c85bb4c3d2f5af9028cd5ebcb2b8aa21bc25df2c1ead5ddfe61ff12cfacec4b92913833e267f8a3fef07fa9a794f4b064fdb472 SHA512 1bf325ffd393447cb90009d01dc1104d0d43a6acdd08cc6d28310063a649a333323748800dab119ab5e10833975e68f5f5702044fc247a2e8058122a5327f2c7
DIST paramiko-3.0.0.gh.tar.gz 350348 BLAKE2B ba7211a3f3c7d4f9c0023017d96ed51511039378b4eba1ace13fbbf6902cda40aa09f2cf7b5ce9f7aee666907d9a662e9bf7eccd5d06669685b9aa25fccfa551 SHA512 3754314fcbd64bf3db5fd6a8d55babc13e639675d09e85d796e99f25eecb55b0f987c0b47bce288c3d154a2dbdb586ecc34bbb09d67786bcc13b0a94a78e6654
diff --git a/dev-python/paramiko/files/paramiko-2.12.0-pytest-relaxed.patch b/dev-python/paramiko/files/paramiko-2.12.0-pytest-relaxed.patch
deleted file mode 100644
index cf34fbfd1c60..000000000000
--- a/dev-python/paramiko/files/paramiko-2.12.0-pytest-relaxed.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-From 935507cc60b6f0b2b83c9c0e3be3900297b41757 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 17 May 2022 07:26:36 +0200
-Subject: [PATCH] Replace pytest-relaxed with plain pytest.raises
-
-There is really no technical reason to bring pytest-relaxed to call
-@raises as a decorator while plain pytest works just fine. Plus,
-pytest.raises() is used in test_sftp already.
-
-pytest-relaxed causes humongous breakage to other packages
-on the system. It has been banned from Gentoo for this reason.
----
- dev-requirements.txt | 1 -
- pytest.ini | 3 ---
- tests/test_client.py | 19 +++++++++----------
- 3 files changed, 9 insertions(+), 14 deletions(-)
-
-diff --git a/dev-requirements.txt b/dev-requirements.txt
-index 3ed9eb40..e90f3373 100644
---- a/dev-requirements.txt
-+++ b/dev-requirements.txt
-@@ -2,7 +2,6 @@
- invoke==1.6.0
- invocations==2.6.0
- pytest==4.4.2
--pytest-relaxed==1.1.5
- # pytest-xdist for test dir watching and the inv guard task
- pytest-xdist==1.28.0
- mock==2.0.0
-diff --git a/pytest.ini b/pytest.ini
-index be207cd8..5a506bcd 100644
---- a/pytest.ini
-+++ b/pytest.ini
-@@ -1,7 +1,4 @@
- [pytest]
--# We use pytest-relaxed just for its utils at the moment, so disable it at the
--# plugin level until we adapt test organization to really use it.
--addopts = -p no:relaxed
- # Loop on failure
- looponfailroots = tests paramiko
- # Ignore some warnings we cannot easily handle.
-diff --git a/tests/test_client.py b/tests/test_client.py
-index 3eaad4fb..66c41b0b 100644
---- a/tests/test_client.py
-+++ b/tests/test_client.py
-@@ -34,7 +34,6 @@ import weakref
- from tempfile import mkstemp
-
- import pytest
--from pytest_relaxed import raises
- from mock import patch, Mock
-
- import paramiko
-@@ -787,11 +786,11 @@ class PasswordPassphraseTests(ClientTest):
-
- # TODO: more granular exception pending #387; should be signaling "no auth
- # methods available" because no key and no password
-- @raises(SSHException)
- @requires_sha1_signing
- def test_passphrase_kwarg_not_used_for_password_auth(self):
-- # Using the "right" password in the "wrong" field shouldn't work.
-- self._test_connection(passphrase="pygmalion")
-+ with pytest.raises(SSHException):
-+ # Using the "right" password in the "wrong" field shouldn't work.
-+ self._test_connection(passphrase="pygmalion")
-
- @requires_sha1_signing
- def test_passphrase_kwarg_used_for_key_passphrase(self):
-@@ -811,15 +810,15 @@ class PasswordPassphraseTests(ClientTest):
- password="television",
- )
-
-- @raises(AuthenticationException) # TODO: more granular
- @requires_sha1_signing
- def test_password_kwarg_not_used_for_passphrase_when_passphrase_kwarg_given( # noqa
- self
- ):
- # Sanity: if we're given both fields, the password field is NOT used as
- # a passphrase.
-- self._test_connection(
-- key_filename=_support("test_rsa_password.key"),
-- password="television",
-- passphrase="wat? lol no",
-- )
-+ with pytest.raises(AuthenticationException):
-+ self._test_connection(
-+ key_filename=_support("test_rsa_password.key"),
-+ password="television",
-+ passphrase="wat? lol no",
-+ )
---
-2.38.1
-
diff --git a/dev-python/paramiko/paramiko-2.12.0.ebuild b/dev-python/paramiko/paramiko-2.12.0.ebuild
deleted file mode 100644
index c7d516f719cc..000000000000
--- a/dev-python/paramiko/paramiko-2.12.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="SSH2 protocol library"
-HOMEPAGE="
- https://www.paramiko.org/
- https://github.com/paramiko/paramiko/
- https://pypi.org/project/paramiko/
-"
-SRC_URI="
- https://github.com/paramiko/paramiko/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
-IUSE="examples server"
-
-RDEPEND="
- >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
- >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/${PN}-2.12.0-pytest-relaxed.patch"
- )
-
- if ! use server; then
- PATCHES+=( "${FILESDIR}/${PN}-2.4.2-disable-server.patch" )
- fi
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r demos/*
- fi
-}