summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-04-22 00:13:42 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-23 10:41:07 +0300
commit5803d337452b52dda141fe8cb483fe6194998f9b (patch)
tree8844a466175c9bc84a17351c0e05a660656580ac /dev-python/patch-ng/patch-ng-1.17.4.ebuild
parentdev-libs/univalue: Bump to 1.0.5 (diff)
downloadgentoo-5803d337452b52dda141fe8cb483fe6194998f9b.tar.gz
gentoo-5803d337452b52dda141fe8cb483fe6194998f9b.tar.bz2
gentoo-5803d337452b52dda141fe8cb483fe6194998f9b.zip
dev-python/patch-ng: update to 1.17.4
Closes: https://bugs.gentoo.org/717516 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/patch-ng/patch-ng-1.17.4.ebuild')
-rw-r--r--dev-python/patch-ng/patch-ng-1.17.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/patch-ng/patch-ng-1.17.4.ebuild b/dev-python/patch-ng/patch-ng-1.17.4.ebuild
new file mode 100644
index 000000000000..39e7235c4fa4
--- /dev/null
+++ b/dev-python/patch-ng/patch-ng-1.17.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Library to parse and apply unified diffs, fork of dev-python/patch"
+HOMEPAGE="https://github.com/conan-io/python-patch-ng https://pypi.org/project/patch-ng/"
+SRC_URI="https://github.com/conan-io/python-patch-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest
+
+S="${WORKDIR}/python-${P}"
+
+python_test() {
+ "${EPYTHON}" -m unittest tests/run_tests.py || die "Tests failed under ${EPYTHON}"
+}