summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-06 19:31:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-06 20:11:47 +0200
commit49b7832b7a3511ed61b8c20aab7619d7b233fabe (patch)
treefff2fdecb5d2f07dd0bfbbdfc144b2be13da2117 /dev-python/pbr
parentdev-python/pydata-sphinx-theme: Remove old (diff)
downloadgentoo-49b7832b7a3511ed61b8c20aab7619d7b233fabe.tar.gz
gentoo-49b7832b7a3511ed61b8c20aab7619d7b233fabe.tar.bz2
gentoo-49b7832b7a3511ed61b8c20aab7619d7b233fabe.zip
dev-python/pbr: Skip Sphinx-based tests
Skip tests requiring dev-python/sphinx, as pbr does not support Sphinx 7 and upstream has removed the relevant bits in git already. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/files/pbr-5.11.1-sphinx-tests.patch32
-rw-r--r--dev-python/pbr/pbr-5.11.1.ebuild5
2 files changed, 33 insertions, 4 deletions
diff --git a/dev-python/pbr/files/pbr-5.11.1-sphinx-tests.patch b/dev-python/pbr/files/pbr-5.11.1-sphinx-tests.patch
new file mode 100644
index 000000000000..0cdb1fe48ec3
--- /dev/null
+++ b/dev-python/pbr/files/pbr-5.11.1-sphinx-tests.patch
@@ -0,0 +1,32 @@
+diff --git a/pbr/tests/test_core.py b/pbr/tests/test_core.py
+index edb7c7b..1730c4f 100644
+--- a/pbr/tests/test_core.py
++++ b/pbr/tests/test_core.py
+@@ -78,6 +78,7 @@ class TestCore(base.BaseTestCase):
+ assert stdout == 'packaging, distutils, setuptools'
+
+ def test_setup_py_build_sphinx(self):
++ self.skipTest("broken with sphinx-7, obsolete")
+ stdout, _, return_code = self.run_setup('build_sphinx')
+ self.assertEqual(0, return_code)
+
+diff --git a/pbr/tests/test_setup.py b/pbr/tests/test_setup.py
+index 4307708..ea5bd3d 100644
+--- a/pbr/tests/test_setup.py
++++ b/pbr/tests/test_setup.py
+@@ -231,6 +231,7 @@ class BaseSphinxTest(base.BaseTestCase):
+
+ def setUp(self):
+ super(BaseSphinxTest, self).setUp()
++ self.skipTest("broken with sphinx-7, obsolete")
+
+ # setup_command requires the Sphinx instance to have some
+ # attributes that aren't set normally with the way we use the
+@@ -379,6 +380,7 @@ class APIAutoDocTest(base.BaseTestCase):
+
+ def setUp(self):
+ super(APIAutoDocTest, self).setUp()
++ self.skipTest("broken with sphinx-7, obsolete")
+
+ # setup_command requires the Sphinx instance to have some
+ # attributes that aren't set normally with the way we use the
diff --git a/dev-python/pbr/pbr-5.11.1.ebuild b/dev-python/pbr/pbr-5.11.1.ebuild
index 5448662cdd64..34c9fbe14271 100644
--- a/dev-python/pbr/pbr-5.11.1.ebuild
+++ b/dev-python/pbr/pbr-5.11.1.ebuild
@@ -29,9 +29,6 @@ RDEPEND="
# https://bugs.gentoo.org/show_bug.cgi?id=561038 docutils is needed for sphinx
# exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848 stestr is run as
# external tool.
-#
-# <dev-python/sphinx-7 is required because of removed build_sphinx hook in
-# setup.py, see https://bugs.launchpad.net/pbr/+bug/2018453
BDEPEND="
test? (
$(python_gen_cond_dep '
@@ -39,7 +36,6 @@ BDEPEND="
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
>=dev-python/six-1.12.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-7[${PYTHON_USEDEP}]
>=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
@@ -51,6 +47,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${P}-importlib-suffixes.patch"
+ "${FILESDIR}/${P}-sphinx-tests.patch"
)
distutils_enable_tests unittest