summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-22 00:47:47 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-22 00:50:56 +0200
commit72be4801df5e6fc11dd03104f2b37fe4c80620f9 (patch)
treebdd91e87e3a749816cfcd655627fb796b49467a0 /dev-python/pipenv
parentdev-python/phonenumbers: Remove old (diff)
downloadgentoo-72be4801df5e6fc11dd03104f2b37fe4c80620f9.tar.gz
gentoo-72be4801df5e6fc11dd03104f2b37fe4c80620f9.tar.bz2
gentoo-72be4801df5e6fc11dd03104f2b37fe4c80620f9.zip
dev-python/pipenv: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/Manifest1
-rw-r--r--dev-python/pipenv/pipenv-2020.6.2.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index 0019ce0e16bb..0d32f4ddc0de 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1,2 +1 @@
-DIST pipenv-2020.6.2.tar.gz 11571734 BLAKE2B bc50535f215b11d284eeec546722a144cfdfeeab6abab8eae51c727c054865f274ac970dc61c23cce7db19ac28a77e44a84453743ba2dc75068feb3a47a19190 SHA512 671765b9e77a18039668eb500989de45c8bd4f15948ee914eb241985098562ebd382168a535a449ac5d216f07327b6787eb8f828b5a6499ef6e77fe5a036441e
DIST pipenv-2020.8.13.tar.gz 11573493 BLAKE2B ac6c6f0336f0c675f73fbecfdefe158eb2a53b5aa4559850b3c9a050404d9d18b0ff2ca3cb62031da027937244a6bbb0d4c1ec433073e429518ec0ea908cb12e SHA512 90ccaf386bc68d856ee9c645084cb65c4213902a8c87e2059cc2274b88d922c3b02c58c15d05945e1f61e8b816ef92a11672cadaf125143bd5019ab25ff0b19e
diff --git a/dev-python/pipenv/pipenv-2020.6.2.ebuild b/dev-python/pipenv/pipenv-2020.6.2.ebuild
deleted file mode 100644
index 49b5811f9f01..000000000000
--- a/dev-python/pipenv/pipenv-2020.6.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_beta/b}
-DESCRIPTION="Python Development Workflow for Humans"
-HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
-SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/pip-18.0[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-clone-0.2.5[${PYTHON_USEDEP}]
- "
-
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- <dev-python/pytest-5[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-
-src_prepare() {
- # remove vendored version of PyYAML that is backported to Python2
- # this should be removed when upstream removes support for Python2
- rm -vR "${S}/${PN}/patched/yaml2/" || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- pytest -m "not cli and not needs_internet" -vv tests/unit || die
-}