summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-09-01 07:23:54 +0200
committerSam James <sam@gentoo.org>2022-11-06 20:12:52 +0000
commit9ca76b61e63037637892f18a0d7f6e11d273d7e1 (patch)
treeeef1358920b02e75e12d4ea2e6fef48c8f8b98b0 /dev-python/pivy/pivy-0.6.8.ebuild
parentsci-mathematics/stp: do not run C API tests (diff)
downloadgentoo-9ca76b61e63037637892f18a0d7f6e11d273d7e1.tar.gz
gentoo-9ca76b61e63037637892f18a0d7f6e11d273d7e1.tar.bz2
gentoo-9ca76b61e63037637892f18a0d7f6e11d273d7e1.zip
dev-python/pivy: add 0.6.8
Closes: https://bugs.gentoo.org/880083 Closes: https://bugs.gentoo.org/867763 Closes: https://github.com/gentoo/gentoo/pull/27101 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pivy/pivy-0.6.8.ebuild')
-rw-r--r--dev-python/pivy/pivy-0.6.8.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pivy/pivy-0.6.8.ebuild b/dev-python/pivy/pivy-0.6.8.ebuild
new file mode 100644
index 000000000000..617534188b57
--- /dev/null
+++ b/dev-python/pivy/pivy-0.6.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Coin3D bindings for Python"
+HOMEPAGE="https://github.com/coin3d/pivy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ PIVY_REPO_URI="https://github.com/coin3d/pivy.git"
+else
+ SRC_URI="https://github.com/coin3d/pivy/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="+quarter soqt test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( quarter soqt )
+"
+
+RDEPEND="
+ >=media-libs/coin-4.0.0
+ quarter? ( media-libs/quarter )
+ soqt? ( >=media-libs/SoQt-1.6.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/swig
+ dev-util/cmake
+ test? ( ${RDEPEND} )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.6-0001-fix-CMakeLists.txt-for-distutils_cmake.patch
+ "${FILESDIR}"/${PN}-0.6.6-0002-Gentoo-specific-clear-swig-deprecation-warning.patch
+ "${FILESDIR}"/${PN}-0.6.7-find-qmake.patch
+)
+
+DOCS=( AUTHORS HACKING NEWS README.md THANKS )
+
+python_test() {
+ # visual_test.py is interactive
+ # pyside_test.py currently fails
+ # quarter_tests.py needs pyside2, which currently lacks py3_11 support
+ for f in tests/coin_tests.py; do
+ "${EPYTHON}" "${f}" || die "Test ${f} failed with ${EPYTHON}"
+ done
+}