summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:58:27 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:58:27 +0200
commit7670e44897e8c836b9852d49188bc706e5d5849d (patch)
tree472a63d07dd7b87b48b702dd55265cb67f927428 /dev-python/poetry-core
parentdev-python/waitress: add 2.1.0 (diff)
downloadgentoo-7670e44897e8c836b9852d49188bc706e5d5849d.tar.gz
gentoo-7670e44897e8c836b9852d49188bc706e5d5849d.tar.bz2
gentoo-7670e44897e8c836b9852d49188bc706e5d5849d.zip
dev-python/poetry-core: add 1.0.8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest1
-rw-r--r--dev-python/poetry-core/poetry-core-1.0.8.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index 4c3631d4a43d..d3833f2d4693 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1 +1,2 @@
DIST poetry-core-1.0.7.gh.tar.gz 414539 BLAKE2B 570f13e3c7298fd822a38b75c49c623bde4fa780b3787c3c9cfa3939bb68fee3eeaf6190013117a6e751cb6f87a15b343ba183529fcc07d30e37988097954d4a SHA512 40a8b17ae7c51135eb5f96ec76426f075075de7dafff8ab828fe3b47d13759856a7fd2e7504c1216c4f942befde2c6d42c3976978202ce7aa224e966162bd8e5
+DIST poetry-core-1.0.8.gh.tar.gz 414941 BLAKE2B 1f663d927aee1f18a9ff38cbf95809538bf9c9e8079d040c240fbc1ffa9e492c6fd20c69f89ddf7e68ddea05beee3b909fdee02e93f47437fffa687dc492ec9a SHA512 6dfed1e1124c37a5f0ec535ede8848e25466da3df6fa6629f6330ce32f05a4d82725d64407e5bcf294d6e467b52966642505ee29f563d3794c4e7aca78045285
diff --git a/dev-python/poetry-core/poetry-core-1.0.8.ebuild b/dev-python/poetry-core/poetry-core-1.0.8.ebuild
new file mode 100644
index 000000000000..f59ecf0e02e4
--- /dev/null
+++ b/dev-python/poetry-core/poetry-core-1.0.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Poetry PEP 517 Build Backend"
+HOMEPAGE="https://pypi.org/project/poetry-core/ https://github.com/python-poetry/poetry-core"
+SRC_URI="
+ https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# check inside src/poetry/core/_vendor/vendor.txt
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lark-parser[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pep517[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Those "fail" bacause of glob file path resulting from newer versions
+ # in our tree than vendored. But those don't affect anything.
+ tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
+ tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
+)
+
+src_prepare() {
+ # remove vendoring of dependencies
+ rm -r poetry/core/_vendor || die
+ sed -e '/__vendor_site__/d' -i poetry/core/__init__.py || die
+
+ distutils-r1_src_prepare
+}