summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 08:30:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 08:32:21 +0200
commit8967bebe14646caf5641fe766487b6586096ccdc (patch)
tree5f5658ead12582d33ecbddaf2de7b7faa90e5dbf /dev-python/poetry-core
parentdev-python/pdm-pep517: Remove old (diff)
downloadgentoo-8967bebe14646caf5641fe766487b6586096ccdc.tar.gz
gentoo-8967bebe14646caf5641fe766487b6586096ccdc.tar.bz2
gentoo-8967bebe14646caf5641fe766487b6586096ccdc.zip
dev-python/poetry-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/poetry-core')
-rw-r--r--dev-python/poetry-core/Manifest1
-rw-r--r--dev-python/poetry-core/poetry-core-1.5.1.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index 49d9b9d29f17..b28d93f31e05 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1,2 +1 @@
-DIST poetry-core-1.5.1.gh.tar.gz 479091 BLAKE2B ff59460a75893c18f9ad0063a880b40c6cff108d03c7f7bd16aaab53a72bf8af2c08af949c448e8703390589112e26c19e9ea9ddfaf2bed69791f86293b62b1c SHA512 ffc2cf6a37175feebe6ae926250d20ebf5742f459824f54b7ad8ea0f65c28639ef1e90a3cbd31bf58fca19d45699c5a22a583cefb5d60795d7e92399bdd1a421
DIST poetry-core-1.5.2.gh.tar.gz 484004 BLAKE2B 56fe974bb37233ee75a220d35dab3d246b9a4145a3abd88981a0c2b9f51cb894b3534746638d7fa75a41451c856261b0b8e737af8778f78fcc9ae894a4b2430f SHA512 e0eab97bcf678f8fd329074d14cb394db8732666b0387384d273db49ec020ff34e15e9982e049bce62e9ba80443404de7646e66433164a2358f9802a8ce2fbb1
diff --git a/dev-python/poetry-core/poetry-core-1.5.1.ebuild b/dev-python/poetry-core/poetry-core-1.5.1.ebuild
deleted file mode 100644
index d53ff8ad2f0e..000000000000
--- a/dev-python/poetry-core/poetry-core-1.5.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Poetry PEP 517 Build Backend"
-HOMEPAGE="
- https://github.com/python-poetry/poetry-core/
- https://pypi.org/project/poetry-core/
-"
-SRC_URI="
- https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# check inside src/poetry/core/_vendor/vendor.txt
-# (note that some are indirect deps)
-RDEPEND="
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/lark[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/pep517[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # These "fail" bacause of glob file path resulting from newer versions
- # in our tree than vendored. But those don't affect anything.
- tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
- tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
-)
-
-src_prepare() {
- # remove vendoring of dependencies
- rm -r src/poetry/core/_vendor || die
- sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- # needed for migration from <1.1
- distutils_write_namespace poetry
- epytest
-}