summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-10 08:23:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-10 08:45:13 +0200
commita5be7dd4eb4b7ca01216d69d3a213d66fa1f91ee (patch)
treeb0c3c451bad46b11eac14ab4aabd25ebec510a78 /dev-python/pretty-yaml
parentdev-python/pikepdf: Bump to 3.2.0 (diff)
downloadgentoo-a5be7dd4eb4b7ca01216d69d3a213d66fa1f91ee.tar.gz
gentoo-a5be7dd4eb4b7ca01216d69d3a213d66fa1f91ee.tar.bz2
gentoo-a5be7dd4eb4b7ca01216d69d3a213d66fa1f91ee.zip
dev-python/pretty-yaml: Bump to 21.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pretty-yaml')
-rw-r--r--dev-python/pretty-yaml/Manifest1
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-21.10.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pretty-yaml/Manifest b/dev-python/pretty-yaml/Manifest
index bf4fe7454e9c..3a3097ae0659 100644
--- a/dev-python/pretty-yaml/Manifest
+++ b/dev-python/pretty-yaml/Manifest
@@ -1 +1,2 @@
+DIST pyaml-21.10.1.tar.gz 20466 BLAKE2B c90adb2023c9555f55a6fafe4e82fa8c50795a9f798250f640d9db6511584f3715a0a8fa4ee3cb26148967c75d59665b05915dd6ef1d4f807bfc7a68f2818482 SHA512 3a98a021856446584f079bfb7427c63feaf6fdd1bd0d809d46aa0c646b2cb9533c393ed0167240be587aad7b94209b6e5bfe2c09918b45ec9a86ad9781bdf9f2
DIST pyaml-21.8.3.tar.gz 20269 BLAKE2B 8b829ce374efe13007bb924393a8cde26914cc443999906b7bb4db610b614964170a80b8dd381eeaa9137026c60d98140b3b0d601a6af816c32d1ce9708e33be SHA512 69b1181511f7d3ac1263b710fa49b18a162e096e28414d83300bc2e9038222363cef995a0d3248387560e7066973736f9cee06b67042ee957427b4790c269653
diff --git a/dev-python/pretty-yaml/pretty-yaml-21.10.1.ebuild b/dev-python/pretty-yaml/pretty-yaml-21.10.1.ebuild
new file mode 100644
index 000000000000..6d353d96ab32
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-21.10.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=pyaml-${PV}
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_P%-*}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest