summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-18 08:57:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-18 08:59:53 +0200
commite4ca3a7b55bd93ba6d55373ae5ee0e52deb26bc2 (patch)
tree063d399bdbe8f944cef7f643255b5b58beb4f78a /dev-python/protobuf-python
parentdev-python/vcrpy: Enable py3.11 (diff)
downloadgentoo-e4ca3a7b55bd93ba6d55373ae5ee0e52deb26bc2.tar.gz
gentoo-e4ca3a7b55bd93ba6d55373ae5ee0e52deb26bc2.tar.bz2
gentoo-e4ca3a7b55bd93ba6d55373ae5ee0e52deb26bc2.zip
dev-python/protobuf-python: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.19.3-r3.ebuild72
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild8
2 files changed, 77 insertions, 3 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-3.19.3-r3.ebuild b/dev-python/protobuf-python/protobuf-python-3.19.3-r3.ebuild
new file mode 100644
index 000000000000..f486c2f2c58c
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-3.19.3-r3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2008-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf"
+ EGIT_SUBMODULES=()
+fi
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="
+ https://developers.google.com/protocol-buffers/
+ https://github.com/protocolbuffers/protobuf/
+ https://pypi.org/project/protobuf/
+"
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="
+ https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz
+ -> protobuf-${PV}.tar.gz
+ "
+fi
+S="${WORKDIR}/protobuf-${PV}/python"
+
+LICENSE="BSD"
+SLOT="0/30"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+"
+RDEPEND="
+ ${BDEPEND}
+ !dev-python/namespace-google
+"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
+fi
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
+ eapply "${FILESDIR}/${PN}-3.19.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ DISTUTILS_ARGS=(--cpp_implementation)
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
+}
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index 9347d6babd62..3541dfec56fd 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -18,6 +19,7 @@ DESCRIPTION="Google's Protocol Buffers - Python bindings"
HOMEPAGE="
https://developers.google.com/protocol-buffers/
https://github.com/protocolbuffers/protobuf/
+ https://pypi.org/project/protobuf/
"
if [[ "${PV}" != "9999" ]]; then
SRC_URI="
@@ -63,7 +65,7 @@ src_configure() {
DISTUTILS_ARGS=(--cpp_implementation)
}
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name "*.pth" -type f -delete || die
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
}