summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyalsaaudio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyalsaaudio')
-rw-r--r--dev-python/pyalsaaudio/Manifest2
-rw-r--r--dev-python/pyalsaaudio/metadata.xml9
-rw-r--r--dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild37
-rw-r--r--dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild40
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/pyalsaaudio/Manifest b/dev-python/pyalsaaudio/Manifest
new file mode 100644
index 000000000000..c84ac6d9de86
--- /dev/null
+++ b/dev-python/pyalsaaudio/Manifest
@@ -0,0 +1,2 @@
+DIST pyalsaaudio-0.7.tar.gz 124577 SHA256 bbd5a9eb351def673800707f48e64680685f397e29da72ea4c9355e1a2b2a0fd SHA512 aea46ebc4a59c791e318e58fa7c307b73ea7e1eafdd6b2055df312e26e8d4868ca582b76dd2f203cb7c632a25e1bfd066f6f9522484aa5db51f404e5f99a38cc WHIRLPOOL 80dd871e66e21ebe34581a0c7ec846dea8b5c5ada93c0b0811334dcf2e90ab97e63852cc47a5355d03e546f335751e949d725f86bc3d26d76ea7aa8e4db9a718
+DIST pyalsaaudio-0.8.2.tar.gz 212747 SHA256 b6df486f1c4035041a5f3800496b86c64e48e4a7d47f94dcbca11b0187aa3a15 SHA512 cba4acaf18b74f990547a590da5bbb824398518444cd09cf80d2e4dcb1176fd5469b107c96b3696ca98ef8ef4d1026feb22b01f730b2558c9dd60ee58500d4b5 WHIRLPOOL 4526ffa3eae6834aa97e8bf55dc90e25c6de5bf6f8345f853a5006a9c7bb1bcb8bd42bbe677d246443213de314400e8e17ef84ef4653d7e7c207151d5a03be33
diff --git a/dev-python/pyalsaaudio/metadata.xml b/dev-python/pyalsaaudio/metadata.xml
new file mode 100644
index 000000000000..3715bb37fcca
--- /dev/null
+++ b/dev-python/pyalsaaudio/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyalsaaudio</remote-id>
+ <remote-id type="sourceforge">pyalsaaudio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild b/dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild
new file mode 100644
index 000000000000..8550d3ac39a0
--- /dev/null
+++ b/dev-python/pyalsaaudio/pyalsaaudio-0.7-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for the ALSA API"
+HOMEPAGE="http://www.sourceforge.net/projects/pyalsaaudio http://pypi.python.org/pypi/pyalsaaudio"
+SRC_URI="mirror://sourceforge/pyalsaaudio/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ~sparc x86"
+IUSE="doc"
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Direct access to ALSA, shouln't be used
+
+DOCS=( CHANGES README )
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ local EXAMPLES=( *test.py )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild b/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
new file mode 100644
index 000000000000..c5d7ce61bbbe
--- /dev/null
+++ b/dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="A Python wrapper for the ALSA API"
+HOMEPAGE="http://www.sourceforge.net/projects/pyalsaaudio http://pypi.python.org/pypi/pyalsaaudio"
+SRC_URI="mirror://sourceforge/pyalsaaudio/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Direct access to ALSA, shouln't be used
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ local EXAMPLES=( *test.py )
+
+ distutils-r1_python_install_all
+}