summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-03 23:54:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-04 00:01:16 +0200
commitf6a6f101e7713ac8d8e659f10d51dc0f3934ba43 (patch)
tree0cce024c623db216b4b6a56c0bd23f1b084369d9 /dev-python/pycairo/pycairo-1.20.1.ebuild
parentdev-util/stripe-mock: Bump to 0.106.0 (diff)
downloadgentoo-f6a6f101e7713ac8d8e659f10d51dc0f3934ba43.tar.gz
gentoo-f6a6f101e7713ac8d8e659f10d51dc0f3934ba43.tar.bz2
gentoo-f6a6f101e7713ac8d8e659f10d51dc0f3934ba43.zip
dev-python/pycairo: Bump to 1.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycairo/pycairo-1.20.1.ebuild')
-rw-r--r--dev-python/pycairo/pycairo-1.20.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pycairo/pycairo-1.20.1.ebuild b/dev-python/pycairo/pycairo-1.20.1.ebuild
new file mode 100644
index 000000000000..1e68e62256d3
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.20.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
+SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=x11-libs/cairo-1.15.10[svg]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests setup.py
+
+python_install() {
+ distutils-r1_python_install \
+ install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}