summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-06-28 11:52:13 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2024-06-28 12:33:24 -0500
commitf6329cb7569a43a46085c7f5d3dc7684dc5daa61 (patch)
tree46579b02e260f85c5bc492e9823bd862ff3c837d /dev-python/pychromecast
parentdev-python/pychromecast: add 14.0.1 (diff)
downloadgentoo-f6329cb7569a43a46085c7f5d3dc7684dc5daa61.tar.gz
gentoo-f6329cb7569a43a46085c7f5d3dc7684dc5daa61.tar.bz2
gentoo-f6329cb7569a43a46085c7f5d3dc7684dc5daa61.zip
dev-python/pychromecast: add 13.1.0
Closes: https://bugs.gentoo.org/929485 Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/pychromecast')
-rw-r--r--dev-python/pychromecast/Manifest1
-rw-r--r--dev-python/pychromecast/pychromecast-13.1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pychromecast/Manifest b/dev-python/pychromecast/Manifest
index 51e51d2a011e..b9b67db2e5e1 100644
--- a/dev-python/pychromecast/Manifest
+++ b/dev-python/pychromecast/Manifest
@@ -1,2 +1,3 @@
DIST PyChromecast-13.0.7.tar.gz 52074 BLAKE2B 4e67ce21bf91c52cd83b8a17d86cd321d937c1f55b567d4df7a5548ad02aacb4c269b9d29030a7e41f9f310d53313b6b287032c1d5f1448b415c3896b168b783 SHA512 dc63c901287ae31ce278c9978701ad335715f1daaab1b2683aa7b02ddb38e3e207f2527ae144f6836b65c4ddb4b1fdd62c40005bf776e0655e647ab40634857e
+DIST PyChromecast-13.1.0.tar.gz 53436 BLAKE2B f8d92f0db9da2898e87340de47bf85cfd71ba4a18ca30af95c261e42c0aff95fcf633637b489a15073c5ed946c4f61370473f07ac83bf37078f37bb90377702a SHA512 a4823b79bf9c54d4734e23cd0c064f9ab51be715297fe02632627812778b2d36600382e18f11e6f368046fb70dc6176a9293888bcbc233cd773443edf4c303c4
DIST PyChromecast-14.0.1.tar.gz 60482 BLAKE2B a34dcba0b975bc8b3c0fb08f5a29a80c2324de3acbcc75dea74cecd5aa9be2fb17fb70f3c2f0131d355edfba5fd0f1d6bdf3d42eb8f368d0b2d3a9f2776f5698 SHA512 72119e27be49128d57a9354aaebd2a5711f3da0ad2e7ca07863107382061d9398c95c901ac33ea2a1c45687b2cbef32dfdba228be99e1acdef79ce133510fb4e
diff --git a/dev-python/pychromecast/pychromecast-13.1.0.ebuild b/dev-python/pychromecast/pychromecast-13.1.0.ebuild
new file mode 100644
index 000000000000..923d1d60979d
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-13.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=PyChromecast
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to talk to Google Chromecast"
+HOMEPAGE="
+ https://github.com/home-assistant-libs/pychromecast/
+ https://pypi.org/project/PyChromecast/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.1[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.25.1[${PYTHON_USEDEP}]
+"