summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-02-23 08:36:16 -0500
committerTim Harder <radhermit@gentoo.org>2018-03-01 14:34:46 -0500
commit90cb10da51c2345ab120cc56db60f6e241b6da3b (patch)
treed8c59c16c4246982d652f79390d431fa7225d857 /dev-python/pyfakefs/pyfakefs-3.3.ebuild
parentdev-python/ply: version bump to 3.11 (diff)
downloadgentoo-90cb10da51c2345ab120cc56db60f6e241b6da3b.tar.gz
gentoo-90cb10da51c2345ab120cc56db60f6e241b6da3b.tar.bz2
gentoo-90cb10da51c2345ab120cc56db60f6e241b6da3b.zip
dev-python/pyfakefs: initial import
Diffstat (limited to 'dev-python/pyfakefs/pyfakefs-3.3.ebuild')
-rw-r--r--dev-python/pyfakefs/pyfakefs-3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/pyfakefs-3.3.ebuild b/dev-python/pyfakefs/pyfakefs-3.3.ebuild
new file mode 100644
index 000000000000..35086811c6ff
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="a fake file system that mocks the Python file system modules"
+HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.python.org/pypi/pyfakefs"
+SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-sandbox-tests.patch )
+
+python_test() {
+ "${PYTHON}" all_tests.py || die "tests failed under ${EPYTHON}"
+}