summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 05:28:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 05:44:12 +0100
commit8a8d40951fbc5e7f321278c4c5106786f61e73e5 (patch)
treefa109cf8b59723f0bd32f27e7db8241c3a992ceb /dev-python/pygal
parentdev-python/prometheus-client: Bump to 0.19.0 (diff)
downloadgentoo-8a8d40951fbc5e7f321278c4c5106786f61e73e5.tar.gz
gentoo-8a8d40951fbc5e7f321278c4c5106786f61e73e5.tar.bz2
gentoo-8a8d40951fbc5e7f321278c4c5106786f61e73e5.zip
dev-python/pygal: Bump to 3.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygal')
-rw-r--r--dev-python/pygal/Manifest1
-rw-r--r--dev-python/pygal/pygal-3.0.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pygal/Manifest b/dev-python/pygal/Manifest
index 3f19d1211fe4..576ee1221c43 100644
--- a/dev-python/pygal/Manifest
+++ b/dev-python/pygal/Manifest
@@ -1 +1,2 @@
DIST pygal-3.0.0.gh.tar.gz 3575455 BLAKE2B 9b64cf441aeb25b0a0b9834f07e5892fe163f28a5da796d37083f8f3a10d8737a69bad39e503d722e6a36f2de4367b4fd2bdc3a06c5bc30bce66a370690d9c88 SHA512 71ac9f197d711c8cf5bb47caef128754f81b1cb0ba98c4cc67de78b68fca5d40baae9fbb5c978f6abaed4c73b8edfea2de07de2fda1aa7c15e0d81387518cc49
+DIST pygal-3.0.3.gh.tar.gz 3575707 BLAKE2B 32dfb09f7dc5f97c758ff516a131da7ab82afb58028d710017af01220dbee57579cadc56e4b9ae207d71ad7d71d05dd14bd876c563f61f18263a0c2a839c0183 SHA512 052852552e0f07194acc832a953cc69131f2640216c22d5f7e5860b98ad80f24a5532a58b52903fedfcdb6e48331e4c8c02be54e90468476ca3f720be8845985
diff --git a/dev-python/pygal/pygal-3.0.3.ebuild b/dev-python/pygal/pygal-3.0.3.ebuild
new file mode 100644
index 000000000000..620264aeebbf
--- /dev/null
+++ b/dev-python/pygal/pygal-3.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A python SVG charts generator"
+HOMEPAGE="
+ https://github.com/Kozea/pygal/
+ https://pypi.org/project/pygal/
+"
+SRC_URI="
+ https://github.com/Kozea/pygal/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]
+ )
+"
+
+# CHANGELOG is a symlink to docs/changelog.rst
+DOCS=( docs/changelog.rst README.md )
+
+distutils_enable_sphinx docs
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Not actually required unless we want to do setup.py test
+ # https://github.com/Kozea/pygal/issues/430
+ sed -i -e "/setup_requires/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "improving rendering speed" "dev-python/lxml"
+ optfeature "png rendering" "dev-python/cairosvg"
+}