summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-08-08 19:33:40 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2023-08-08 19:34:21 +0200
commit2fa60efc36c5c9444a070b840fdb0c3a89afc2c9 (patch)
tree368ecec98f41607759bd6cc942ddaacc804025ad /dev-python/pygccxml
parentapp-portage/gentoopm: Stabilize 0.5.0 ppc64, #911893 (diff)
downloadgentoo-2fa60efc36c5c9444a070b840fdb0c3a89afc2c9.tar.gz
gentoo-2fa60efc36c5c9444a070b840fdb0c3a89afc2c9.tar.bz2
gentoo-2fa60efc36c5c9444a070b840fdb0c3a89afc2c9.zip
dev-python/pygccxml: add 2.3.0
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/Manifest1
-rw-r--r--dev-python/pygccxml/pygccxml-2.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
index 509860418241..c98076c800aa 100644
--- a/dev-python/pygccxml/Manifest
+++ b/dev-python/pygccxml/Manifest
@@ -1 +1,2 @@
DIST pygccxml-2.2.1.gh.tar.gz 3170283 BLAKE2B b53123c59d098f56d97841225d10ffd4156b993244e48c4ad30e2f62b6d95d69e0ae4bbfc86bb492e88e8f52d916401f29a6ec7024277d1e32b3af691a12e919 SHA512 32013617d4d632617b616d3787631c5b09da441a87bb15b88e3b287f17b85e1388308e85dd385276966ac09114536a5863edd5fbb96539547783fd2d41c6e8ce
+DIST pygccxml-2.3.0.gh.tar.gz 3165248 BLAKE2B 177591d818f3ff91b7981ee1b1af9d03f79869508cddd03ece8f3b5e447982dc2d9434fa42db290c98d8c5fb4f4ee4ae7ef86e2b065dc28ba4b7843a36cad4e1 SHA512 6c5710c842c8e6101af73335ea66dc18ae86861f9cd5c59b4aa1037f60914934ba22a821d7f35cf954f5c40800433bacfc0d4bd0ae1bb5946a4dd950c606ceea
diff --git a/dev-python/pygccxml/pygccxml-2.3.0.ebuild b/dev-python/pygccxml/pygccxml-2.3.0.ebuild
new file mode 100644
index 000000000000..745417525398
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-2.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="A specialized XML reader to navigate C++ declarations"
+HOMEPAGE="https://github.com/CastXML/pygccxml"
+SRC_URI="https://github.com/CastXML/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/castxml
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}