summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 08:50:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 08:52:42 +0100
commit00ac452118c676fa38aa115a1dcc6075de6bfc2c (patch)
treead4699e3b80481dd0fbe1794d131e014e2e8b897 /dev-python/pygresql
parentdev-python/python-lsp-black: Bump to 1.1.0 (diff)
downloadgentoo-00ac452118c676fa38aa115a1dcc6075de6bfc2c.tar.gz
gentoo-00ac452118c676fa38aa115a1dcc6075de6bfc2c.tar.bz2
gentoo-00ac452118c676fa38aa115a1dcc6075de6bfc2c.zip
dev-python/pygresql: Bump to 5.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygresql')
-rw-r--r--dev-python/pygresql/Manifest1
-rw-r--r--dev-python/pygresql/pygresql-5.2.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index eb92599eee0c..eeaf21151278 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1 +1,2 @@
DIST PyGreSQL-5.2.2.tar.gz 268818 BLAKE2B 4b74c5496f63208164efa10e70222b63512f3afb928bdc612f9874556ee2084b42a80ba05e9ebc6951c68c1c8a70c71320396aabb20b9d5c00d5edd46e287f3f SHA512 a88af2590a515ece19b7f64796e241c6e7b53c8aef90c6e2ae064298a4c71d44695dcf43e0e84595a704c4fdafb9abe35e1779492d3a9ad3708759215cb188a1
+DIST PyGreSQL-5.2.3.tar.gz 269952 BLAKE2B 9588f4e97dcc2b52e070405df3869c50bb9968716f19fa2154b6aa248d015c7b80aa6d2bf12a3bb30a77e4572b96939b5a6a98043fe70c911f80a54e09cb034e SHA512 94fe212801e89a97ccaac0cd72df4a79e28acc0992e855dfc2e8e8fd08750c97d2f2801eef07fdfa8a258061cc63c4aa9e4127852ba58c845414ec2d5e5f1483
diff --git a/dev-python/pygresql/pygresql-5.2.3.ebuild b/dev-python/pygresql/pygresql-5.2.3.ebuild
new file mode 100644
index 000000000000..b9bd244ac38a
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.2.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+POSTGRES_COMPAT=( 9.6 {10..14} )
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 postgres
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="https://pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2-CFLAGS.patch
+)
+
+distutils_enable_tests unittest
+
+src_test() {
+ local db="${T}/pgsql"
+ initdb --username=portage -D "${db}" || die
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U portage -d postgres \
+ -c "ALTER ROLE portage WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U portage unittest || die
+
+ cat > tests/LOCAL_PyGreSQL.py <<-EOF || die
+ dbhost = '${T}'
+ EOF
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}