summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-13 07:11:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-13 07:30:07 +0200
commit868f68c4ea74c3b67f8e78e8d98fbf2460deea75 (patch)
tree89c29495db9f18fb9d91a78dd65f94c0b1d9858e /dev-python/pyicu
parentapp-admin/awscli: Bump to 1.22.94 (diff)
downloadgentoo-868f68c4ea74c3b67f8e78e8d98fbf2460deea75.tar.gz
gentoo-868f68c4ea74c3b67f8e78e8d98fbf2460deea75.tar.bz2
gentoo-868f68c4ea74c3b67f8e78e8d98fbf2460deea75.zip
dev-python/pyicu: Bump to 2.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyicu')
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index b17e2b3ae48a..e07953887f28 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1 +1,2 @@
DIST pyicu-v2.8.1.tar.bz2 242774 BLAKE2B eeb3c45124301b7072addcbfc3c97521d21fbdb5bdf2b0fe94f0181c225927a0b3bd6ab6271140fa9928d0220e5cb33c800b367cf4b0cf844ad64a2438aa016b SHA512 dc7fb292322c565da045db9d91e9b4cd58a559d6f78bf3f050bf25fbab942179b463b977340e08bbeb107e3a2be8a2eb0a0a91911e0c0b8b96327ba85fd13c46
+DIST pyicu-v2.9.tar.bz2 243533 BLAKE2B c2ea32f69637e2d12a57ded96b570ba7fd41c92aed4a0dea36ebe5c224b80fa8d1672251f8218e0a35d463957ab4291cff778c3e690f0763e465dc6f0a1af26d SHA512 f10025afe1a0de5a1726c3d4aaec5b10ba62064c33205117efe643185dcd3560e8971b600606e9699269cca795477bf86ed2f9e604e9c0e04bb75a86f31cd114
diff --git a/dev-python/pyicu/pyicu-2.9.ebuild b/dev-python/pyicu/pyicu-2.9.ebuild
new file mode 100644
index 000000000000..84a153bb0fca
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/
+"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/icu:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest