summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-07-25 11:54:49 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-07-25 13:25:32 +0200
commit8b99cc747f124c15d29f07d0bc4006992edb3bd4 (patch)
tree03870f0d104af0d802e959925a5628f1a416f7f7 /dev-python/pyinsane/pyinsane-2.0.10.ebuild
parentdev-lang/crystal: bump up to 0.23.1, bug #626114 (diff)
downloadgentoo-8b99cc747f124c15d29f07d0bc4006992edb3bd4.tar.gz
gentoo-8b99cc747f124c15d29f07d0bc4006992edb3bd4.tar.bz2
gentoo-8b99cc747f124c15d29f07d0bc4006992edb3bd4.zip
dev-python/pyinsane: 2.0.10 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/pyinsane/pyinsane-2.0.10.ebuild')
-rw-r--r--dev-python/pyinsane/pyinsane-2.0.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyinsane/pyinsane-2.0.10.ebuild b/dev-python/pyinsane/pyinsane-2.0.10.ebuild
new file mode 100644
index 000000000000..53eb32c51fba
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-2.0.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/openpaperwork/pyinsane"
+SRC_URI="https://github.com/openpaperwork/pyinsane/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="media-gfx/sane-backends
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # Tests require at least one scanner with a flatbed and an ADF
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" \
+ -e "s/find_packages()/find_packages(exclude=['examples','tests'])/" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}