summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-03 13:49:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-03 14:30:02 +0100
commit70100fcdded5b74427fb52efbd7c7e12c8842b03 (patch)
treeebcddc40f129f5a0a90b4316e20838371545b26c /dev-python/pylibmc
parentdev-python/cryptography: Remove old (diff)
downloadgentoo-70100fcdded5b74427fb52efbd7c7e12c8842b03.tar.gz
gentoo-70100fcdded5b74427fb52efbd7c7e12c8842b03.tar.bz2
gentoo-70100fcdded5b74427fb52efbd7c7e12c8842b03.zip
dev-python/pylibmc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylibmc')
-rw-r--r--dev-python/pylibmc/pylibmc-1.6.3.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/pylibmc/pylibmc-1.6.3.ebuild b/dev-python/pylibmc/pylibmc-1.6.3.ebuild
deleted file mode 100644
index 275388aca075..000000000000
--- a/dev-python/pylibmc/pylibmc-1.6.3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Libmemcached wrapper written as a Python extension"
-HOMEPAGE="
- https://sendapatch.se/projects/pylibmc/
- https://pypi.org/project/pylibmc/
- https://github.com/lericson/pylibmc/
-"
-SRC_URI="
- https://github.com/lericson/pylibmc/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86"
-
-DEPEND="
- >=dev-libs/libmemcached-0.32
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- test? (
- net-misc/memcached
- )
-"
-
-PATCHES=(
- "${FILESDIR}/pylibmc-1.6.1-fix-test-failures-r1.patch"
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-# needed for docs
-export PYLIBMC_DIR=.
-
-src_test() {
- local -x MEMCACHED_PORT=11219
- memcached -d -p "${MEMCACHED_PORT}" -u nobody -l localhost \
- -P "${T}/m.pid" || die
- distutils-r1_src_test
- kill "$(<"${T}/m.pid")" || die
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these require "AmazonElastiCache" running
- tests/test_autoconf.py
- )
-
- epytest --doctest-modules --doctest-glob='doctests.txt' src/pylibmc tests
-}