summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pymetar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pymetar')
-rw-r--r--dev-python/pymetar/Manifest1
-rw-r--r--dev-python/pymetar/files/setup.patch14
-rw-r--r--dev-python/pymetar/metadata.xml16
-rw-r--r--dev-python/pymetar/pymetar-0.19-r1.ebuild24
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pymetar/Manifest b/dev-python/pymetar/Manifest
new file mode 100644
index 000000000000..aef058ffca84
--- /dev/null
+++ b/dev-python/pymetar/Manifest
@@ -0,0 +1 @@
+DIST pymetar-0.19.tar.gz 22123 SHA256 2666c9bcb171bcc5cd6c174073a280836f049fbbd9c264ea24a2a023edb647c9 SHA512 2d6f93db41743eceee776f17dd57ce626b89e19d538a9e52a5a984c3ff858ae42abc5c6f129bceda6efccfd2ae7f1c9616f5b82d7e3795cc38d5ece430aec2a6 WHIRLPOOL cad04c3d8415ff67ff0a08070b787e61321eb7836aeafc3fe326382d9d81c46ac41045ead7100b9561d51dc268bd70522782c2d7937901843a3cf03605ad9a49
diff --git a/dev-python/pymetar/files/setup.patch b/dev-python/pymetar/files/setup.patch
new file mode 100644
index 000000000000..d953af0be4c5
--- /dev/null
+++ b/dev-python/pymetar/files/setup.patch
@@ -0,0 +1,14 @@
+entry for data_files cause unwanted duplicate entry @ install
+diff -u pymetar-0.19.orig/setup.py pymetar-0.19/setup.py
+--- setup.py 2012-01-25 22:01:19.000000000 +0800
++++ setup.py 2015-01-04 10:57:14.698948559 +0800
+@@ -26,7 +26,5 @@
+ packages= [ "" ],
+ py_modules=["pymetar"],
+ scripts = [ "bin/pymetar" ],
+- data_files = [("share/doc/pymetar-%s"%pymetar.__version__,
+- ['README', 'COPYING', 'THANKS', 'librarydoc.txt']),
+- ("share/man/man1", ['pymetar.1'])]
++ data_files = [("share/man/man1", ['pymetar.1'])]
+ )
+
diff --git a/dev-python/pymetar/metadata.xml b/dev-python/pymetar/metadata.xml
new file mode 100644
index 000000000000..110abde3a93a
--- /dev/null
+++ b/dev-python/pymetar/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+This library downloads the weather report for a given station
+ID (get yours from http://www.nws.noaa.gov/tg/siteloc.shtml),
+decodes it and provides easy access to all the data found in the
+report. Documentation and a small example app are inside the tarball.
+</longdescription>
+<longdescription lang="ja">
+このライブラリは指定したステーションID( http://www.nws.noaa.gov/tg/siteloc.shtml で入手)から天気予報結果をダウンロードし、解読し、予報データから検索するのに簡単
+なアクセス手段を提供します。ドキュメンテーションと単純なサンプル・アプリケーショ
+ンはtarballファイルの中です。
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pymetar/pymetar-0.19-r1.ebuild b/dev-python/pymetar/pymetar-0.19-r1.ebuild
new file mode 100644
index 000000000000..dc61ff545c50
--- /dev/null
+++ b/dev-python/pymetar/pymetar-0.19-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Downloads, decodes and provides access to the weather report for a given station ID"
+HOMEPAGE="http://www.schwarzvogel.de/software-pymetar.shtml"
+SRC_URI="http://www.schwarzvogel.de/pkgs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="librarydoc.txt README THANKS"
+
+# Fix to install of data
+PATCHES=( "${FILESDIR}"/setup.patch )