summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 08:24:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 10:05:29 +0200
commitad3d5c8f1296acbe8111bb320e45a79b7e9499c3 (patch)
tree3137783a5002f0892ffeb32e3e02eff41d487d51 /dev-python/pyparsing/pyparsing-3.0.9.ebuild
parentapp-admin/awscli: Bump to 1.23.11 (diff)
downloadgentoo-ad3d5c8f1296acbe8111bb320e45a79b7e9499c3.tar.gz
gentoo-ad3d5c8f1296acbe8111bb320e45a79b7e9499c3.tar.bz2
gentoo-ad3d5c8f1296acbe8111bb320e45a79b7e9499c3.zip
dev-python/pyparsing: Bump to 3.0.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing/pyparsing-3.0.9.ebuild')
-rw-r--r--dev-python/pyparsing/pyparsing-3.0.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyparsing/pyparsing-3.0.9.ebuild b/dev-python/pyparsing/pyparsing-3.0.9.ebuild
new file mode 100644
index 000000000000..5dd04e79a482
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2004-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}