summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-25 17:52:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-25 20:09:23 +0100
commitd8134f0f69c3aa42c3e1ff21c37261d28a648cb4 (patch)
tree080da3866949463bb6315577ecf04e3c1c678506 /dev-python/pyperclip/pyperclip-1.7.0.ebuild
parentdev-python/precis-i18n: Remove old (diff)
downloadgentoo-d8134f0f69c3aa42c3e1ff21c37261d28a648cb4.tar.gz
gentoo-d8134f0f69c3aa42c3e1ff21c37261d28a648cb4.tar.bz2
gentoo-d8134f0f69c3aa42c3e1ff21c37261d28a648cb4.zip
dev-python/pyperclip: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyperclip/pyperclip-1.7.0.ebuild')
-rw-r--r--dev-python/pyperclip/pyperclip-1.7.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/pyperclip/pyperclip-1.7.0.ebuild b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
deleted file mode 100644
index ed8610f66825..000000000000
--- a/dev-python/pyperclip/pyperclip-1.7.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1 virtualx
-
-DESCRIPTION="A cross-platform clipboard module for Python."
-HOMEPAGE="https://github.com/asweigart/pyperclip"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc64 sparc x86"
-
-RDEPEND="
- || (
- (
- x11-misc/xsel
- sys-apps/which
- )
- (
- x11-misc/xclip
- sys-apps/which
- )
- (
- kde-plasma/plasma-workspace
- sys-apps/which
- )
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP}]
- )
-"
-# test at least one backend
-BDEPEND="
- test? (
- ${RDEPEND}
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-test-pyqt.patch
-)
-
-src_prepare() {
- # stupid windows
- find -type f -exec sed -i -e 's:\r$::' {} + || die
- # klipper is hard to get working, and once we make it work,
- # it breaks most of the other backends
- sed -e 's:_executable_exists("klipper"):False:' \
- -i tests/test_pyperclip.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${EPYTHON}" tests/test_pyperclip.py -vv ||
- die "Tests fail on ${EPYTHON}"
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}