summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-08 19:41:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-08 19:42:09 +0100
commit1c070074a8313496462ed216bedd53b82bb5fff1 (patch)
tree762f1ec82f4636beefa4f69820aeae7062a593b6 /dev-python/pyproj/pyproj-2.4.1.ebuild
parentdev-python/pyproj: bump to 2.4.2 (diff)
downloadgentoo-1c070074a8313496462ed216bedd53b82bb5fff1.tar.gz
gentoo-1c070074a8313496462ed216bedd53b82bb5fff1.tar.bz2
gentoo-1c070074a8313496462ed216bedd53b82bb5fff1.zip
dev-python/pyproj: Drop 2.4.1
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pyproj/pyproj-2.4.1.ebuild')
-rw-r--r--dev-python/pyproj/pyproj-2.4.1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/pyproj/pyproj-2.4.1.ebuild b/dev-python/pyproj/pyproj-2.4.1.ebuild
deleted file mode 100644
index 52b61f2b5316..000000000000
--- a/dev-python/pyproj/pyproj-2.4.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Python < 3.6 requires https://pypi.org/project/aenum/
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python interface to the PROJ library"
-HOMEPAGE="https://github.com/jswhit/pyproj"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="doc"
-
-RDEPEND=">=sci-libs/proj-6.2.0"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/Shapely[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_check_deps() {
- use doc || return 0
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- append-cflags -fno-strict-aliasing
-}
-
-python_test() {
- PROJ_LIB="${EPREFIX}/usr/share/proj" pytest -ra || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}