summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 07:39:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 07:52:01 +0100
commit5f2678bb6c5ce796da6d8c6232e499d91ef853fc (patch)
tree7336ce5bfedca61ad5b37536e293081c22d8022f /dev-python/pyproject-fmt
parentdev-python/tenacity: Bump to 8.2.1 (diff)
downloadgentoo-5f2678bb6c5ce796da6d8c6232e499d91ef853fc.tar.gz
gentoo-5f2678bb6c5ce796da6d8c6232e499d91ef853fc.tar.bz2
gentoo-5f2678bb6c5ce796da6d8c6232e499d91ef853fc.zip
dev-python/pyproject-fmt: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.8.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 9e385287b765..3e3f78ee9d27 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -2,3 +2,4 @@ DIST pyproject-fmt-0.4.1.gh.tar.gz 14853 BLAKE2B e06e3602290fdc4df00fb48dfe9d6d5
DIST pyproject-fmt-0.5.0.gh.tar.gz 14906 BLAKE2B f75482988c8e10fbfcffaa518e6004f0e96b922e8bf929e43c7be26cf16149b3fa97a3070fabfbb90641ee3d953ab17bd854ba2e107b776f65f6bc802980bd54 SHA512 58ec7975f7c69990b1d2a0ee8a29681731d7143e59754343dc64e52e135cc5d280adf3c31b6818f042982697a7221a36aa0842ffba1ede28b57cefad77bf065c
DIST pyproject-fmt-0.6.0.gh.tar.gz 15082 BLAKE2B 9ec7126530c98b984c5346bfd65fa817967dc7def60d16eb93e63ff690eaad53209d49483e19b5e87caf7b879f6661862a68606a0adb3b4513ff119262ff99a6 SHA512 50c9dcb468213de62e86edd500ae001815a83d8374ac1d36467fd7c560a5774862b001414f687d588fc0622ba5896c83338d6833ac4c248d2b4aa111fefe33ce
DIST pyproject-fmt-0.7.0.gh.tar.gz 15249 BLAKE2B ad3b86af31ed860efb5eefbdd62629c3f3dfdb79a01b1e9904bf5a808699e410d870ca688fc82e28307b07841502f57870754cd694c10998ab1e1e0eef177669 SHA512 361a7bbb4a96659d3902ddb317c2f9b49999010aca4b91f8663d810971d6d1bb0362e26cc63ee7b16b0e1e1518af429b57d06de71bcfc56efad462dfc2c04abe
+DIST pyproject-fmt-0.8.0.gh.tar.gz 15307 BLAKE2B 270a07220bc5b2bb81502de55727dd92d7a0cbde33c5d2a202d1b41de44a08ebd84f26bfd6c0cdcc1793f494f880c9a5e3db391069796dd6cbab6bdf1e4e6f64 SHA512 12f622176a9032173d73dbe21ab3da89ab9c3cf8c49e22b3d7e30abd5d1f9c4d988e519025a2d60a17324e449df719fd67f58d7c1ed49de9b9f50573863dad9f
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.8.0.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.8.0.ebuild
new file mode 100644
index 000000000000..a802c14c305f
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+SRC_URI="
+ https://github.com/tox-dev/pyproject-fmt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-23[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}