summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-03 21:28:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-05 10:42:21 +0200
commit1da144bd8fc45e9aea4f40cd34a56274289132e2 (patch)
tree0f290ac9fa9bb0e4937be065beca8abed9424725 /dev-python/pypy3
parentdev-python/pypy3_10: Make test packages optional (diff)
downloadgentoo-1da144bd8fc45e9aea4f40cd34a56274289132e2.tar.gz
gentoo-1da144bd8fc45e9aea4f40cd34a56274289132e2.tar.bz2
gentoo-1da144bd8fc45e9aea4f40cd34a56274289132e2.zip
dev-python/pypy3: Add transitive USE=test-install
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/38384 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/metadata.xml6
-rw-r--r--dev-python/pypy3/pypy3-7.3.17-r1.ebuild26
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pypy3/metadata.xml b/dev-python/pypy3/metadata.xml
index 922f8a45d05d..edfebd49d8c1 100644
--- a/dev-python/pypy3/metadata.xml
+++ b/dev-python/pypy3/metadata.xml
@@ -8,4 +8,10 @@
<upstream>
<remote-id type="heptapod">pypy/pypy</remote-id>
</upstream>
+ <use>
+ <flag name="test-install">
+ Install the test suite packages, that are required to run
+ tests in a few reverse dependencies.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/dev-python/pypy3/pypy3-7.3.17-r1.ebuild b/dev-python/pypy3/pypy3-7.3.17-r1.ebuild
new file mode 100644
index 000000000000..1539b0b89ab8
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.17-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYVER=3.10
+DESCRIPTION="A fast, compliant alternative implementation of the Python (${PYVER}) language"
+HOMEPAGE="
+ https://pypy.org/
+ https://foss.heptapod.net/pypy/pypy/
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0/pypy310-pp73-384"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+gdbm ncurses sqlite +test-install tk"
+
+RDEPEND="
+ =dev-python/pypy3_10-${PV}*:${SLOT}[gdbm?,ncurses?,sqlite?,test-install(+)?,tk?]
+"
+
+src_install() {
+ dodir /usr/bin
+ dosym pypy${PYVER} /usr/bin/pypy3
+}