summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-29 07:05:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-29 07:05:03 +0200
commitecb3de9985f455a8a8084784f2c355b2f43ca330 (patch)
tree61594054cafe49bce55b98fbcbadd640c6ab742f /dev-python/pyspnego
parentdev-python/pyproject-fmt: Bump to 0.11.1 (diff)
downloadgentoo-ecb3de9985f455a8a8084784f2c355b2f43ca330.tar.gz
gentoo-ecb3de9985f455a8a8084784f2c355b2f43ca330.tar.bz2
gentoo-ecb3de9985f455a8a8084784f2c355b2f43ca330.zip
dev-python/pyspnego: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyspnego')
-rw-r--r--dev-python/pyspnego/Manifest1
-rw-r--r--dev-python/pyspnego/pyspnego-0.9.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index 05da4a1d68a5..1c3710b41abd 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1 +1,2 @@
DIST pyspnego-0.8.0.tar.gz 222900 BLAKE2B aa526c6506f680008ded0a86e938629ccc9ca89454d7987017903e9e5fe26204346bd4eefae3a35c641309391a4784c23e1a3e51d8a03f5ab517516e1a3a4965 SHA512 d9d6356cf9d78fde6669606df7b56f0004957ed58f94cd3965d63827df702ffc10299296153f8c089853f3b22a684e08129d607b4eaedfd332b8b82652119e89
+DIST pyspnego-0.9.0.tar.gz 233612 BLAKE2B 62047b84c5bcc5085e75abe167c6909f0a34a403c182f9bb03994e8e78768c4f1859e68b0e25d27271c6f686565c68d090a8825c0136a18e3443f734bee2f4db SHA512 4fa03d54ee47441a7255fb8b93b4616937ce96c76de4d8255ff48e60fff0112d6cd802458e151d4cf92f3710f7c415ea5499c460fb2f291155b3a1820ba37623
diff --git a/dev-python/pyspnego/pyspnego-0.9.0.ebuild b/dev-python/pyspnego/pyspnego-0.9.0.ebuild
new file mode 100644
index 000000000000..202be95d8916
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}