summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-20 15:31:35 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-20 17:48:54 +0200
commit7deec6c8d2f5f001e412c8129c6d9167f815b6f2 (patch)
treee0a3d7dfbbbd5d76249a776038636d1772d9efc0 /dev-python/pytest-asyncio
parentdev-python/pytest-asyncio: Set DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-7deec6c8d2f5f001e412c8129c6d9167f815b6f2.tar.gz
gentoo-7deec6c8d2f5f001e412c8129c6d9167f815b6f2.tar.bz2
gentoo-7deec6c8d2f5f001e412c8129c6d9167f815b6f2.zip
dev-python/pytest-asyncio: Use distutils_enable_tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
index f7b4cfba907b..b5141f97fa04 100644
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
@@ -16,11 +16,7 @@ SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> $
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]"
DEPEND="
test? (
${RDEPEND}
@@ -32,6 +28,8 @@ PATCHES=(
"${FILESDIR}"/pytest-asyncio-0.10.0-py38.patch
)
+distutils_enable_tests pytest
+
python_test() {
distutils_install_for_testing
pytest -vv || die "Tests fail with ${EPYTHON}"