summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 11:17:16 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 11:22:15 +0100
commita997eab87d009253daee4ca6abd366ecf33aab6b (patch)
tree8c857e3acfa5e4158fa64a78638b2eaf5066c35d /dev-python/pytest-asyncio
parentdev-python/widgetsnbextension: Remove old (diff)
downloadgentoo-a997eab87d009253daee4ca6abd366ecf33aab6b.tar.gz
gentoo-a997eab87d009253daee4ca6abd366ecf33aab6b.tar.bz2
gentoo-a997eab87d009253daee4ca6abd366ecf33aab6b.zip
dev-python/pytest-asyncio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/files/pytest-asyncio-0.23.4-pytest-8.patch47
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.2.ebuild49
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.4-r1.ebuild57
4 files changed, 0 insertions, 155 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 98925d7ad73e..31900c1ce33c 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1 @@
-DIST pytest-asyncio-0.23.2.tar.gz 44174 BLAKE2B 36dbd0022416eef05c781b9f74fd143bb52fe0583461ca7e52fd4981d552bbefdddd8e3a3399bc229a8ae68b150e199237ae0ce3a375075ab8f7f507bfa59316 SHA512 aa5b5fe8b633b187303dd2958d2ea01561604044507da107e46115d9bf4c1ac3c78826b4b6a6cbf474a6ee4ce0cd1bede87a2c8fe0d35397ddf6a4069437dd84
-DIST pytest-asyncio-0.23.4.tar.gz 45162 BLAKE2B 69092bff908beb2b707d281142145edf0508bcb09aa59e4a91d18b3cdb24e5533436a9668e2d243425b4914f2913e6186fa6d8b6c1d187b6bf25191986d27981 SHA512 831c572ae981b8575f97dd4d0d40d960d49cbeeb6b186e1c094eb45b1f48210824780ca14cbf44d1da558b1a17ca1fefc0eda26137461172bbd12f8b25ab8ebb
DIST pytest-asyncio-0.23.5.tar.gz 45887 BLAKE2B 6f641d3c614c5a224f51278ba6021ed40f015a30aa19999cca7803cc3b50e91e8a0e3c997fbd6905801a10fda5f6c2de9f2ce3228d6f1a3f734e81ebd9f0796c SHA512 112ddaa0cf8c05cec4e99cb55df4db1b7d9929b13aa531172b442cff4cd49fbe12ec23ff12aaa260f303919c840c13b21c00a94990e4b107fb115c4850a33b47
diff --git a/dev-python/pytest-asyncio/files/pytest-asyncio-0.23.4-pytest-8.patch b/dev-python/pytest-asyncio/files/pytest-asyncio-0.23.4-pytest-8.patch
deleted file mode 100644
index d18c5714005b..000000000000
--- a/dev-python/pytest-asyncio/files/pytest-asyncio-0.23.4-pytest-8.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From d53c12962fd7250bea28e03b5a141be73cfce06b Mon Sep 17 00:00:00 2001
-From: Arjan Keeman <akeeman@users.noreply.github.com>
-Date: Tue, 6 Feb 2024 14:46:13 +0100
-Subject: [PATCH] fix compatibility with pytest ^8
-
-diff --git a/setup.cfg b/setup.cfg
-index 45d70b3..e8cbfc5 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -40,5 +40,5 @@ include_package_data = True
- install_requires =
-- pytest >= 7.0.0,<8
-+ pytest >= 7.0.0, !=8.0.0rc1, !=8.0.0rc2
-
- [options.extras_require]
- testing =
-diff --git a/tests/markers/test_session_scope.py b/tests/markers/test_session_scope.py
-index bd0baee..9049c17 100644
---- a/tests/markers/test_session_scope.py
-+++ b/tests/markers/test_session_scope.py
-@@ -44,7 +44,9 @@ def test_asyncio_mark_provides_session_scoped_loop_strict_mode(pytester: Pyteste
- """
- ),
- )
-- subpackage_name = "subpkg"
-+
-+ # subpackage_name must alphabetically come after test_module_one.py
-+ subpackage_name = "z_subpkg"
- subpkg = pytester.mkpydir(subpackage_name)
- subpkg.joinpath("test_subpkg.py").write_text(
- dedent(
-diff --git a/tests/test_is_async_test.py b/tests/test_is_async_test.py
-index 512243b..12e791c 100644
---- a/tests/test_is_async_test.py
-+++ b/tests/test_is_async_test.py
-@@ -77,8 +77,10 @@ def test_returns_false_for_unmarked_coroutine_item_in_strict_mode(pytester: Pyte
- if pytest.version_tuple < (7, 2):
- # Probably related to https://github.com/pytest-dev/pytest/pull/10012
- result.assert_outcomes(failed=1)
-- else:
-+ elif pytest.version_tuple < (8,):
- result.assert_outcomes(skipped=1)
-+ else:
-+ result.assert_outcomes(failed=1)
-
-
- def test_returns_true_for_unmarked_coroutine_item_in_auto_mode(pytester: Pytester):
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.2.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.2.ebuild
deleted file mode 100644
index 84f1303a694a..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.23.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
- tests/modes/test_legacy_mode.py
- tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
- tests/test_pytest_min_version_warning.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
- epytest
-}
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.4-r1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.4-r1.ebuild
deleted file mode 100644
index 22c4e61869b2..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.23.4-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/pytest-dev/pytest-asyncio/pull/776
- "${FILESDIR}/${P}-pytest-8.patch"
-)
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
- tests/modes/test_legacy_mode.py
- tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
- tests/test_pytest_min_version_warning.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
-
- # TODO
- tests/test_is_async_test.py::test_returns_false_for_unmarked_coroutine_item_in_strict_mode
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
- epytest
-}