summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-03 06:19:48 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-03 06:46:58 +0100
commite0496702e705b271a190467fc6e701fe1fe53c06 (patch)
treec2cd9733bf2aa82cf85d3e9ae85884dcee8134b8 /dev-python/pytest-asyncio
parentdev-python/django-tables2: Bump to 2.7.5 (diff)
downloadgentoo-e0496702e705b271a190467fc6e701fe1fe53c06.tar.gz
gentoo-e0496702e705b271a190467fc6e701fe1fe53c06.tar.bz2
gentoo-e0496702e705b271a190467fc6e701fe1fe53c06.zip
dev-python/pytest-asyncio: Bump to 0.25.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.25.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 36d11be52470..533906b2354c 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1 +1,2 @@
DIST pytest_asyncio-0.25.0.tar.gz 53298 BLAKE2B e29641f9e0ae24aac80bca7eaa14258d0bdfa6080abeaedd38ffe121cb9a9bf5886da2a38a3033010fcb47f4c2aee0eb17b0f63cee020c5ae81e8334486c66b7 SHA512 162d1693c82c4be96cf20cfeb075c4e434e897cdfc172564b8b2513b362a6bbf54d8be6da4a63a7de34236b6c55eb515e60b994198c07a5c63a63333fe019932
+DIST pytest_asyncio-0.25.1.tar.gz 53760 BLAKE2B e7e30691734c0c0c0783f152531b6e3e7455098b577a0ae87d560959e5fbd7a3a04148b85b13543a69763022b49d5d946af089a2ad0cedae5d9f3470643c1e6e SHA512 8a6ce121dfce4362a9b9dd320ee8207129a5f9d667e80fc8d6b9a43095883cfbbb59813e2fafc5deae062c596b2a9af76b80b18fabcc003fbecf9a0fc8b09e01
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.25.1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.25.1.ebuild
new file mode 100644
index 000000000000..ea77c34a602f
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.25.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-5.7.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
+ epytest
+}