summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-03 16:26:07 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-03 16:37:34 +0100
commit3b19ff13584e873f47cb936d36aea60935838ed8 (patch)
tree6a2625f6383b4937a795614543a42e31907b50fd /dev-python/pytest-bdd
parentxfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.10 (diff)
downloadgentoo-3b19ff13584e873f47cb936d36aea60935838ed8.tar.gz
gentoo-3b19ff13584e873f47cb936d36aea60935838ed8.tar.bz2
gentoo-3b19ff13584e873f47cb936d36aea60935838ed8.zip
dev-python/pytest-bdd: Bump to 7.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 8e405a1ff14e..d73e536d2f07 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1 +1,2 @@
DIST pytest-bdd-7.0.0.gh.tar.gz 80196 BLAKE2B cb34f5439959e93ccb68c566e284d1789a183dd85c1c3088d0c929373e88bd994de2ac159ea942119183976e64903cf7ca8f2b2137aad749f8b67728c541ee89 SHA512 0f95334a56ff7ccc774e5b94b91d232b829fb308a21ce975c88720493abbefa9e76fcd35cc2ca9bbbf0fd2e38b6f20f5be6cf59368aab4cf70abdaf24c7fd5ed
+DIST pytest-bdd-7.0.1.gh.tar.gz 80315 BLAKE2B 7838a71fc6f0e7a86337d3b4d4fb9e0e7a3a0149c4271ecd75b5c9b40a28ad6bf3d6ccbc90d4a49a5472ae158f7710d98f91be340e67995ba47ea729584d16e5 SHA512 60d9713485a4719c6589e6641b45045e79c063278359c14ccbd016a6b0a8c8eebbf93e61d59e037988247c0116023910aa5e6776896b64dc96dcc23d0dbf6e3b
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.0.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.0.1.ebuild
new file mode 100644
index 000000000000..29cf3065023a
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-7.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pytest-bdd.readthedocs.io/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}