summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-07 06:07:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-07 06:40:41 +0200
commit4813aa27edd311666a8df54d420a7fa90228b40d (patch)
tree11dca7058315855d2b75ce45f6ce126b1f36ff37 /dev-python/pytest-check
parentapp-doc/python-docs: Bump to 3.10.12 (diff)
downloadgentoo-4813aa27edd311666a8df54d420a7fa90228b40d.tar.gz
gentoo-4813aa27edd311666a8df54d420a7fa90228b40d.tar.bz2
gentoo-4813aa27edd311666a8df54d420a7fa90228b40d.zip
dev-python/pytest-check: Bump to 2.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-check')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/pytest-check-2.1.5.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
index c8f491c364e5..7c7037110490 100644
--- a/dev-python/pytest-check/Manifest
+++ b/dev-python/pytest-check/Manifest
@@ -1 +1,2 @@
DIST pytest-check-2.1.4.tar.gz 24770 BLAKE2B 72973951e900276e771c083ad8869afbff5305c922c4cbc3fa02b302c6c72f24616ec89f25c2cbc7a2fbe333a4a8c00e2436a2f55345cc8b9791a1e5c2e64125 SHA512 8bf110f7c8e7d76c394ece5b6ba83cdf4ebc459d3a79541c5077237a1caecd0ecc82a74ebc796de9cbc921f48d1c739d1c40dcbd9c2efa3b1ab01f0234238bed
+DIST pytest_check-2.1.5.tar.gz 24990 BLAKE2B d7b09fe1f4b2932b4d9cfc12e0cc3a2c8082a97727cc6bec01f0db32b67af5860c8677749bf48068e496896fdf5a6beab57eb1fb39facddfb8defa995ff1ccfd SHA512 b3886f96db1ca20e4d337ea527e38e67faa1d79ace3c2cde2760ff66bc7fb5a77eeca2d3833a0abcf16e6f1f6922a82a8fddf7949ddf78e5238c9018761f2829
diff --git a/dev-python/pytest-check/pytest-check-2.1.5.ebuild b/dev-python/pytest-check/pytest-check-2.1.5.ebuild
new file mode 100644
index 000000000000..cdaa78e83590
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-2.1.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest