summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-11 19:12:47 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-11 21:04:08 +0200
commit2554ca31c6cdc96b032f00047c72d40eceeb857d (patch)
tree8b2eb866e305881bcc45f5e965feac09eead247c /dev-python/pytest-cov
parentdev-python/Faker: Remove old (diff)
downloadgentoo-2554ca31c6cdc96b032f00047c72d40eceeb857d.tar.gz
gentoo-2554ca31c6cdc96b032f00047c72d40eceeb857d.tar.bz2
gentoo-2554ca31c6cdc96b032f00047c72d40eceeb857d.zip
dev-python/pytest-cov: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.1.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index e5e398892086..5e6613bf2053 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,2 +1 @@
-DIST pytest-cov-4.1.0.tar.gz 63245 BLAKE2B ed69b96f2117fb924c47b5d80c4e01ec2ab27162ee31a91943e72927a919fe194a8a67ee86eb6bae68ac5a34288c91c57edd8a4800dbffca83f7da4006792d04 SHA512 1280e338ad236ae6757e4538a641fef740bee6c85c5af1f649ba4f28fd99f84ff1048ae40b8633d1751ea248788c1efd401aa078b3aa5929a9249514e5722fc1
DIST pytest-cov-5.0.0.tar.gz 63042 BLAKE2B 6a0f3b38bbf6ae8843d804d078b3879e76ef146ba1bee2eb068bffe560332984994a8405964be185b2ededc2c8231288e609573c5a83143147eeb537659da1e5 SHA512 384459cafdb800711b935899acc3716f5fcbc28b40be0e168e58333603b1dea474bbd7a92f09b6afbe2f9dc1ce8599668a787c0f93884c263af894f44311a4a6
diff --git a/dev-python/pytest-cov/pytest-cov-4.1.0.ebuild b/dev-python/pytest-cov/pytest-cov-4.1.0.ebuild
deleted file mode 100644
index e3c664021481..000000000000
--- a/dev-python/pytest-cov/pytest-cov-4.1.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="pytest plugin for coverage reporting"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-cov/
- https://pypi.org/project/pytest-cov/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
- >=dev-python/coverage-6.4.4-r1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.0.0-pytest-xdist-2.5.0.patch
-)
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-py3doc-enhanced-theme
-distutils_enable_tests pytest
-
-python_test() {
- # NB: disabling all plugins speeds tests up a lot
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_cov.plugin,xdist.plugin,xdist.looponfail
-
- local src=$(
- "${EPYTHON}" -c "import coverage as m; print(*m.__path__)" || die
- )
- # TODO: why do we need to do that?!
- # https://github.com/pytest-dev/pytest-cov/issues/517
- ln -s "${src}" \
- "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
-
- nonfatal epytest -n "$(makeopts_jobs)" --dist=worksteal
- local ret=${?}
-
- rm "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
-
- [[ ${ret} -ne 0 ]] && die "epytest failed on ${EPYTHON}"
-}