summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-27 06:20:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-27 06:49:28 +0200
commitc983d77f025311858f5c4ebe61f89c887c43e2ff (patch)
tree9b965dfa64b2eaf6f0c85285b2f37db3faec3412 /dev-python/pytest-datadir
parentapp-arch/xarchiver: Bump to 0.5.4.20 (diff)
downloadgentoo-c983d77f025311858f5c4ebe61f89c887c43e2ff.tar.gz
gentoo-c983d77f025311858f5c4ebe61f89c887c43e2ff.tar.bz2
gentoo-c983d77f025311858f5c4ebe61f89c887c43e2ff.zip
dev-python/pytest-datadir: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-datadir')
-rw-r--r--dev-python/pytest-datadir/Manifest1
-rw-r--r--dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-datadir/Manifest b/dev-python/pytest-datadir/Manifest
index ae3460d06b15..c1d4aefe5c9b 100644
--- a/dev-python/pytest-datadir/Manifest
+++ b/dev-python/pytest-datadir/Manifest
@@ -1 +1,2 @@
DIST pytest-datadir-1.3.1.tar.gz 15230 BLAKE2B 72c5daaeb93315be55ae052d39a22eee4e64a1aaafa344ae64b527eebd137dc4667cee2f60af887551f00814d7ea4e5788097d0f59f7769335545c5083aef356 SHA512 2ab035ea4e6c4eaaead746a5fd3988feed31a314f73e18270faf4ae606521aa045f3d6c5e1301adcb87f8fd5b1ba5f3f1784f212ad778707ba46ad638d594f8c
+DIST pytest-datadir-1.4.1.tar.gz 7862 BLAKE2B 6ecd0ba76706c2fedf5964b3f6476176b2eb858fff9207b6286f6235d13c173f62fd03abeab2f5e5fd31506ee436c731d9786fe7937620bb1de08bb50f7b492d SHA512 e9a301004275235787de11242fe987665e4fcc89ca2d1168b27686f4d1506e506bdd517658edcbf2aca97b28dcb1869653e16412157b8ef313c1d4146f8cf4d8
diff --git a/dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild b/dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild
new file mode 100644
index 000000000000..ddd6c606dc8b
--- /dev/null
+++ b/dev-python/pytest-datadir/pytest-datadir-1.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for manipulating test data directories and files"
+HOMEPAGE="
+ https://github.com/gabrielcnr/pytest-datadir/
+ https://pypi.org/project/pytest-datadir/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest