summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-23 16:21:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 23:09:40 +0100
commit4b2249c3fddc596c6cc9f1d1306f7168a64d1c67 (patch)
tree23aa920b371ba789015017da5a50136ca3b8f5dc /dev-python/pytest-flake8
parentdev-vcs/git-cola: Disable pytest-flake8 (diff)
downloadgentoo-4b2249c3fddc596c6cc9f1d1306f7168a64d1c67.tar.gz
gentoo-4b2249c3fddc596c6cc9f1d1306f7168a64d1c67.tar.bz2
gentoo-4b2249c3fddc596c6cc9f1d1306f7168a64d1c67.zip
dev-python/pytest-flake8: Enable pytest-flake8 plugin explicitly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-flake8')
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild b/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
index 6398ac03bfb8..907b852ec5cb 100644
--- a/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
+++ b/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,3 +17,7 @@ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 x86"
RDEPEND=">=dev-python/flake8-3.5.0[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
+
+python_test() {
+ epytest -p flake8
+}