summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-06 14:37:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-06 14:37:49 +0200
commit86d6eb787e0b5acd8f47c02cf2e37ed6d964931b (patch)
tree3c42670e2a2e634ac9890061df697bfbe6b8eea3 /dev-python/pytest-lazy-fixtures
parentdev-python/croniter: Remove old (diff)
downloadgentoo-86d6eb787e0b5acd8f47c02cf2e37ed6d964931b.tar.gz
gentoo-86d6eb787e0b5acd8f47c02cf2e37ed6d964931b.tar.bz2
gentoo-86d6eb787e0b5acd8f47c02cf2e37ed6d964931b.zip
dev-python/pytest-lazy-fixtures: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-lazy-fixtures')
-rw-r--r--dev-python/pytest-lazy-fixtures/Manifest2
-rw-r--r--dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild34
-rw-r--r--dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild31
3 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/pytest-lazy-fixtures/Manifest b/dev-python/pytest-lazy-fixtures/Manifest
index d80d6fd28874..c07007f89702 100644
--- a/dev-python/pytest-lazy-fixtures/Manifest
+++ b/dev-python/pytest-lazy-fixtures/Manifest
@@ -1,3 +1 @@
-DIST pytest-lazy-fixtures-1.0.5.gh.tar.gz 20107 BLAKE2B 543f1a2c9a134fc238c686286b81367c3d6ad21b0bb4b171e2c00f1b961a7813a6c6b141dd265a360c40da7d6e1fd0d48c5ea8d8fc3804a09a39447c0c1c7970 SHA512 c84bce864c5e482c5115ba4c1c8caec9e97a85af4fc839a9fa3a472306d12e1c4564cf4323545be2c6af52c1dc22c24a3e25eae434696953f9efd5d822663601
-DIST pytest_lazy_fixtures-1.0.6.tar.gz 6734 BLAKE2B 96790ba540258d2b197fc4043dbc4cfe2c4b2b899208dbf0ff16308c273e775e9bb7661c0b07f64f54658fb76cc942f1530e31584613da7b60c9c1cf63742ed9 SHA512 d8db7c39178dff14b358d389f0fd5b481ffdfa256b5d8cfd7a810c8fb632a687ff95eebb9988cd9f82f85f6169a8e6a625783fd35831a6fe8db3a23949719c25
DIST pytest_lazy_fixtures-1.0.7.tar.gz 6958 BLAKE2B e8bd937592fc0773077712517655f25a3051263c3ef0a9450e78a22b3e69fa028ecbe17b8f9c5d4e38eff263a2a3a8cb5b0a64e0ca77cd47c80b3128f9a46122 SHA512 abb4cc08d3a3a3de5e1df2df7df8b9f552cefc715408b402a738ebc0368475480f63c627d49b7fe0bdfdb468f15cfc8e568ac1057511f9f9cc4c13231a8c3e71
diff --git a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild
deleted file mode 100644
index b62c708bfe26..000000000000
--- a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.5.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Allows you to use fixtures in @pytest.mark.parametrize"
-HOMEPAGE="
- https://github.com/dev-petrov/pytest-lazy-fixtures/
- https://pypi.org/project/pytest-lazy-fixtures/
-"
-SRC_URI="
- https://github.com/dev-petrov/pytest-lazy-fixtures/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/pytest-7[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild
deleted file mode 100644
index 43d0138b5f59..000000000000
--- a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Allows you to use fixtures in @pytest.mark.parametrize"
-HOMEPAGE="
- https://github.com/dev-petrov/pytest-lazy-fixtures/
- https://pypi.org/project/pytest-lazy-fixtures/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/pytest-7[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_lazy_fixtures.plugin
- epytest
-}