summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-05 15:08:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-05 19:10:11 +0300
commit00ea22af58d63eceb4df686d0dc7a847a81ff54b (patch)
tree72577d6efcb4e52a10d7fcb856c0ff4477c1880e /dev-python/pytest-plus
parentdev-python/pysvg: EAPI=8, PEP517 (diff)
downloadgentoo-00ea22af58d63eceb4df686d0dc7a847a81ff54b.tar.gz
gentoo-00ea22af58d63eceb4df686d0dc7a847a81ff54b.tar.bz2
gentoo-00ea22af58d63eceb4df686d0dc7a847a81ff54b.zip
dev-python/pytest-plus: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-plus')
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-plus/pytest-plus-0.2-r1.ebuild b/dev-python/pytest-plus/pytest-plus-0.2-r1.ebuild
new file mode 100644
index 000000000000..975ff22ff399
--- /dev/null
+++ b/dev-python/pytest-plus/pytest-plus-0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyTest Plus Plugin - extends pytest functionality"
+HOMEPAGE="https://github.com/pytest-dev/pytest-plus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest