summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 10:31:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 11:13:16 +0100
commit94f918abd574c964255f73f51e17ef770db67a67 (patch)
tree3c7a47eae8eacd3a3a16db1f4bdbd71fa8b37525 /dev-python/pytest-regressions
parentdev-python/pytest-regressions: Make test deps on mpl & pillow opt. (diff)
downloadgentoo-94f918abd574c964255f73f51e17ef770db67a67.tar.gz
gentoo-94f918abd574c964255f73f51e17ef770db67a67.tar.bz2
gentoo-94f918abd574c964255f73f51e17ef770db67a67.zip
dev-python/pytest-regressions: Make numpy test-dep optional
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-regressions')
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild
index 42f0a8168f29..1f4d0d4876b9 100644
--- a/dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild
+++ b/dev-python/pytest-regressions/pytest-regressions-2.3.1.ebuild
@@ -24,7 +24,6 @@ RDEPEND="
BDEPEND="
test? (
- dev-python/numpy[${PYTHON_USEDEP}]
dev-python/tox[${PYTHON_USEDEP}]
)"
@@ -39,6 +38,11 @@ python_test() {
tests/test_image_regression.py::test_image_regression
)
fi
+ if ! has_version "dev-python/numpy[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_ndarrays_regression.py
+ )
+ fi
if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
EPYTEST_DESELECT+=(
tests/test_filenames.py::test_foo