summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-25 10:25:05 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-25 13:18:32 +0200
commitec484ecf87c494d32bd3d46394c7a16bb521c751 (patch)
treee2db2e9fbd72f08d3865c9e571b17e29486f5923 /dev-python/pytest-runner/pytest-runner-2.6.2.ebuild
parentwww-servers/resin: Drop vunerable version. Fixes security bug 431416. (diff)
downloadgentoo-ec484ecf87c494d32bd3d46394c7a16bb521c751.tar.gz
gentoo-ec484ecf87c494d32bd3d46394c7a16bb521c751.tar.bz2
gentoo-ec484ecf87c494d32bd3d46394c7a16bb521c751.zip
dev-python/pytest-runner: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytest-runner/pytest-runner-2.6.2.ebuild')
-rw-r--r--dev-python/pytest-runner/pytest-runner-2.6.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/pytest-runner-2.6.2.ebuild b/dev-python/pytest-runner/pytest-runner-2.6.2.ebuild
new file mode 100644
index 000000000000..ca7dafb1cfe7
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-2.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests durring installation of setup.py files"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-runner https://bitbucket.org/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ "
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+# Test not included
+RESTRICT="test"
+
+python_compile_all() {
+ # The build by rst2html.py makes non fatal errors building index.rst
+ if use doc; then
+ rst2html.py docs/history.rst > docs/history.html
+ rst2html.py docs/index.rst > docs/index.html
+ fi
+}
+
+python_test() {
+ esetup.py pytest
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}