summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-29 08:24:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-29 08:24:29 +0100
commit35e31907482d9659006816570cd5b62dcc460fc4 (patch)
tree76db705251fae97a6932dad3e45ca9a06f9bcbb3 /dev-python/pytest-subtests
parentdev-python/charset_normalizer: Stabilize 3.0.1 ALLARCHES, #883477 (diff)
downloadgentoo-35e31907482d9659006816570cd5b62dcc460fc4.tar.gz
gentoo-35e31907482d9659006816570cd5b62dcc460fc4.tar.bz2
gentoo-35e31907482d9659006816570cd5b62dcc460fc4.zip
dev-python/pytest-subtests: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.8.0.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index f03ec7f71117..a6a2ac1af939 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,2 +1 @@
-DIST pytest-subtests-0.8.0.gh.tar.gz 9767 BLAKE2B 707f6744f1cd7723d7bee11f5e535750fa179e7ad3912cd94d5200002e1dc0a206cbdb5c3bc8be587a1c81342ef9d6a8a397acd08388096a484feca6f9c84e0c SHA512 0164e02c81685108bb5c12f7e7ce92dc2fd5c844be454b2cb26e3cb942d51c453f06bb48e0300438a82b28c747dea35ea4f75eaf65ff8b66b338bcb0f0dd9ed1
DIST pytest-subtests-0.9.0.gh.tar.gz 9840 BLAKE2B c94155c1e44b4bf81bc4d2d1963c952b721634372db9dc5c1b8a7819acba8e84815333c0c67a90d2a930abb98affbd99a721796ed09513635923f6a89e336d4a SHA512 f1bc2b99e6f04864cdc45675574d32821fd5e08c01c937bddc846ac509cd8906d21ee63b11e9e8a87c2631334541e9adc601a7dd69702572d51c3d4b72443ad2
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.8.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.8.0.ebuild
deleted file mode 100644
index ac20291c5208..000000000000
--- a/dev-python/pytest-subtests/pytest-subtests-0.8.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="unittest subTest() support and subtests fixture"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-subtests/
- https://pypi.org/project/pytest-subtests/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/pytest-7[${PYTHON_USEDEP}]
-"
-# pytest-xdist is used to test compatibility
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
- local EPYTEST_DESELECT=()
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # broken by output changes
- # https://github.com/pytest-dev/pytest-subtests/issues/69
- "tests/test_subtests.py::TestSubTest::test_simple_terminal_normal[unittest]"
- "tests/test_subtests.py::TestSubTest::test_simple_terminal_verbose[unittest]"
- )
-
- epytest
-}