summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 23:35:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-14 00:13:53 +0100
commit3af4ac823c686cdcc1ebee4cdd80318ef0d49b8d (patch)
tree45953fb9b5fb8b2efe00d5567b4b61a00c400a63 /dev-python/pytest-subtests
parentdev-python/nuitka: Bump to 0.6.19.7 (diff)
downloadgentoo-3af4ac823c686cdcc1ebee4cdd80318ef0d49b8d.tar.gz
gentoo-3af4ac823c686cdcc1ebee4cdd80318ef0d49b8d.tar.bz2
gentoo-3af4ac823c686cdcc1ebee4cdd80318ef0d49b8d.zip
dev-python/pytest-subtests: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest1
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.7.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index b9caba38ac9b..c5f2c46ed776 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,2 +1,3 @@
DIST pytest-subtests-0.5.0.tar.gz 9793 BLAKE2B c671eb14189c0fd34180a636592b20c9e2b4225c5faf3b702103164e60bdbac4c9644e464f1e0c783da3da1263f7b841ea7a4149bcbf1de23325a8ef3ce5c030 SHA512 e3d7e90c3ab66950eb80d25049bc6f6f75b08b3da5ce0de5f3fc55d6a176a8d1fdcb19a19f7d9d137aeadcc82b214550474f76d5611bc5592ca649ddd8257a2a
DIST pytest-subtests-0.6.0.gh.tar.gz 9698 BLAKE2B 7b8f8c78ca503d107466d1ff34830aa08c3c5ec9b0f9e962b0e61472bf4f7413eb7e71db5768d898d476eb186a5a14c6703f14a990eb57c8664153a4ac384678 SHA512 9b4fa2e1957388f0e61a13a3cce95976fb5fdea64def627c5a1bf75049a0272e82f19ed9aa117bac0d02c6fd8832f22e7cfe409694ea81920def49742142eb93
+DIST pytest-subtests-0.7.0.gh.tar.gz 9714 BLAKE2B 027badb226c6889ed2fb809eb0b3944ef227a804ea58562fe9337f37526a07a41b11cdfd356d8e9a29f9affc9d0702dead59045db9781504c92186ee613ccb1a SHA512 96531a42c06a20cdf3f3665993d3e80d198a60d536246f4dc46df20b56e47f3f6fdce9478351a8922e370435f974e63d565550213fbbeed8487eedc131f46404
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.7.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.7.0.ebuild
new file mode 100644
index 000000000000..253798d9aa9c
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-python/pytest-7[${PYTHON_USEDEP}]"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+ epytest
+}