summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 14:49:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 15:14:49 +0200
commite1a09a2e34cfe38b5220d811e2fc2a6ed89e1c2e (patch)
tree79c3e0f2a5a22c20b4c316d68e1fa545fb1d4fbe /dev-python/pytest-virtualenv
parentdev-python/pytest-shutil: Enable py3.11 (diff)
downloadgentoo-e1a09a2e34cfe38b5220d811e2fc2a6ed89e1c2e.tar.gz
gentoo-e1a09a2e34cfe38b5220d811e2fc2a6ed89e1c2e.tar.bz2
gentoo-e1a09a2e34cfe38b5220d811e2fc2a6ed89e1c2e.zip
dev-python/pytest-virtualenv: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-virtualenv')
-rw-r--r--dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..88600e1f00db
--- /dev/null
+++ b/dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="
+ https://github.com/man-group/pytest-plugins/
+ https://pypi.org/project/pytest-virtualenv/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-shutil[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest